[tarantool-patches] Re: [PATCH 04/12] vinyl: rename compact to compaction
vdavydov.dev at gmail.com
Thu Jan 17 15:08:19 MSK 2019
On Thu, Jan 17, 2019 at 02:34:49PM +0300, Konstantin Osipov wrote:
> * Vladimir Davydov <vdavydov.dev at gmail.com> [19/01/15 17:20]:
> > compact_input sounds confusing, because 'compact' works as an adjective
> > here. Saving 3 characters per variable/stat name related to compaction
> > doesn't justify this. Let's rename 'compact' to 'compaction' both in
> > stats and in the code.
> Actually, compaction_input also can be confused with the current
> compaction queue size. Perhaps we could play with word "total" to
> distinguish the current/last amounts and the total amounts in variable
The names are long enough as they are so I'd avoid adding total_
prefixes. For queue, we have compaction_queue.
More information about the Tarantool-patches