[tarantool-patches] Re: [PATCH 04/12] vinyl: rename compact to compaction

Konstantin Osipov kostja at tarantool.org
Thu Jan 17 14:34:49 MSK 2019

* Vladimir Davydov <vdavydov.dev at gmail.com> [19/01/15 17:20]:
> compact_input sounds confusing, because 'compact' works as an adjective
> here. Saving 3 characters per variable/stat name related to compaction
> doesn't justify this. Let's rename 'compact' to 'compaction' both in
> stats and in the code.

Actually, compaction_input also can be confused with the current
compaction queue size. Perhaps we could play with word "total" to
distinguish the current/last amounts and the total amounts in variable

Konstantin Osipov, Moscow, Russia, +7 903 626 22 32
http://tarantool.io - www.twitter.com/kostja_osipov

More information about the Tarantool-patches mailing list