[tarantool-patches] Re: [PATCH 10/12] vinyl: rename key stmt construction routine

Konstantin Osipov kostja at tarantool.org
Thu Feb 21 14:15:30 MSK 2019

* Vladimir Davydov <vdavydov.dev at gmail.com> [19/02/21 13:31]:
> Currently, it's called vy_stmt_new_select, but soon a key statement will
> be allowed to have any type, not just IPROTO_SELECT. So let's rename it
> to vy_stmt_new_key. Let's also rename the wrapper vy_key_from_msgpack to
> vy_stmt_new_key_from_array, because its key feature is that in contrast
> to vy_stmt_new_key it takes a msgpack array instead of key data + part
> count.

I like the new names, vy_stmt_new_key_from_array - maybe
vy_stmt_new_key_from_msgpack after all?

Konstantin Osipov, Moscow, Russia, +7 903 626 22 32
http://tarantool.io - www.twitter.com/kostja_osipov

More information about the Tarantool-patches mailing list