[tarantool-patches] Re: [PATCH 10/12] vinyl: rename key stmt construction routine

Vladimir Davydov vdavydov.dev at gmail.com
Thu Feb 21 15:14:36 MSK 2019

On Thu, Feb 21, 2019 at 02:15:30PM +0300, Konstantin Osipov wrote:
> * Vladimir Davydov <vdavydov.dev at gmail.com> [19/02/21 13:31]:
> > Currently, it's called vy_stmt_new_select, but soon a key statement will
> > be allowed to have any type, not just IPROTO_SELECT. So let's rename it
> > to vy_stmt_new_key. Let's also rename the wrapper vy_key_from_msgpack to
> > vy_stmt_new_key_from_array, because its key feature is that in contrast
> > to vy_stmt_new_key it takes a msgpack array instead of key data + part
> > count.
> I like the new names, vy_stmt_new_key_from_array - maybe
> vy_stmt_new_key_from_msgpack after all?

But vy_stmt_new_key also takes msgpack so we'd have two functions both
taking msgpack, called vy_stmt_new_key and vy_stmt_new_key_from_msgpack.
Looks confusing IMO. Not that it really matters to me. I can rename it
if you think it's OK.

More information about the Tarantool-patches mailing list