[Tarantool-patches] [PATCH v2 04/16] sql: rename sqlPrepare() to sql_compile()

Nikita Pettik korablev at tarantool.org
Fri Dec 13 16:49:20 MSK 2019


On 03 Dec 23:51, Vladislav Shpilevoy wrote:
> Thanks for the patch!
> 
> > diff --git a/src/box/sql/sqlInt.h b/src/box/sql/sqlInt.h
> > index 3ca10778e..07c26e932 100644
> > --- a/src/box/sql/sqlInt.h
> > +++ b/src/box/sql/sqlInt.h
> > @@ -468,6 +468,19 @@ typedef void (*sql_destructor_type) (void *);
> >  #define SQL_STATIC      ((sql_destructor_type)0)
> >  #define SQL_TRANSIENT   ((sql_destructor_type)-1)
> >  
> > +/**
> > + * Compile the UTF-8 encoded SQL statement zSql into a statement handle.
> 
> Please, keep 66 symbols border, and remove 'zSql'.

diff --git a/src/box/sql/sqlInt.h b/src/box/sql/sqlInt.h
index 07c26e932..3bdbc0c38 100644
--- a/src/box/sql/sqlInt.h
+++ b/src/box/sql/sqlInt.h
@@ -469,7 +469,8 @@ typedef void (*sql_destructor_type) (void *);
 #define SQL_TRANSIENT   ((sql_destructor_type)-1)
 
 /**
- * Compile the UTF-8 encoded SQL statement zSql into a statement handle.
+ * Compile the UTF-8 encoded SQL statement into
+ * a statement handle (struct Vdbe).
  *
  * @param sql UTF-8 encoded SQL statement.
  * @param sql_len Length of @sql in bytes.> 


More information about the Tarantool-patches mailing list