[Tarantool-patches] [PATCH v2 04/16] sql: rename sqlPrepare() to sql_compile()
Vladislav Shpilevoy
v.shpilevoy at tarantool.org
Wed Dec 4 01:51:23 MSK 2019
Thanks for the patch!
> diff --git a/src/box/sql/sqlInt.h b/src/box/sql/sqlInt.h
> index 3ca10778e..07c26e932 100644
> --- a/src/box/sql/sqlInt.h
> +++ b/src/box/sql/sqlInt.h
> @@ -468,6 +468,19 @@ typedef void (*sql_destructor_type) (void *);
> #define SQL_STATIC ((sql_destructor_type)0)
> #define SQL_TRANSIENT ((sql_destructor_type)-1)
>
> +/**
> + * Compile the UTF-8 encoded SQL statement zSql into a statement handle.
Please, keep 66 symbols border, and remove 'zSql'.
> + *
> + * @param sql UTF-8 encoded SQL statement.
> + * @param sql_len Length of @sql in bytes.
> + * @param re_prepared VM being re-compiled. Can be NULL.
> + * @param[out] stmt A pointer to the compiled statement.
> + * @param[out] sql_tail End of parsed string.
> + */
> +int
> +sql_compile(const char *sql, int bytes_count, struct Vdbe *re_prepared,
> + sql_stmt **stmt, const char **sql_tail);
> +
> int
> sql_step(sql_stmt *);
>
>
More information about the Tarantool-patches
mailing list