From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from smtp40.i.mail.ru (smtp40.i.mail.ru [94.100.177.100]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by dev.tarantool.org (Postfix) with ESMTPS id 49757440F3C for ; Wed, 6 Nov 2019 18:07:55 +0300 (MSK) From: Vladislav Shpilevoy Date: Wed, 6 Nov 2019 18:13:43 +0300 Message-Id: MIME-Version: 1.0 Content-Transfer-Encoding: 8bit Subject: [Tarantool-patches] [PATCH v2 0/3] JSON preparation part 5 List-Id: Tarantool development patches List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: tarantool-patches@dev.tarantool.org, kostja.osipov@gmail.com The patchset is a fifth part of preparations to JSON updates of a tuple. It reorganizes code. Before the path there was one huge file implementing xrow update. Soon amount of the code will be much larger, and a new code structure was needed to be able to maintain it. Now xrow update implementation consists of several files. One file for general update functions and structures, one file for top-level API used by other tarantool code, and one file per each non-trivial type of xrow field update. By the idea, each xrow_update_.c will implement update of one of field types such as array, bar, map, route. It allows to make these implementations independent and easy to support. Branch: http://github.com/tarantool/tarantool/tree/gerold103/gh-1261-update-json-preparation-5 Issue: https://github.com/tarantool/tarantool/issues/1261 Changes in v2: - Flattened xrow_update/ directory. Vladislav Shpilevoy (3): tuple: rename tuple_update.c/h to xrow_update.c/h tuple: rename tuple_update_* to xrow_update_* tuple: rework updates to improve code extendibility src/box/CMakeLists.txt | 4 +- src/box/lua/tuple.c | 9 +- src/box/memtx_space.c | 26 +- src/box/space.c | 30 +- src/box/tuple.c | 11 +- src/box/tuple.h | 2 +- src/box/tuple_update.c | 1520 --------------------- src/box/vinyl.c | 22 +- src/box/vy_upsert.c | 14 +- src/box/xrow_update.c | 502 +++++++ src/box/{tuple_update.h => xrow_update.h} | 36 +- src/box/xrow_update_array.c | 302 ++++ src/box/xrow_update_field.c | 665 +++++++++ src/box/xrow_update_field.h | 442 ++++++ test/box/tuple.result | 4 +- test/unit/column_mask.c | 8 +- 16 files changed, 1994 insertions(+), 1603 deletions(-) delete mode 100644 src/box/tuple_update.c create mode 100644 src/box/xrow_update.c rename src/box/{tuple_update.h => xrow_update.h} (70%) create mode 100644 src/box/xrow_update_array.c create mode 100644 src/box/xrow_update_field.c create mode 100644 src/box/xrow_update_field.h -- 2.21.0 (Apple Git-122.2)