From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from localhost (localhost [127.0.0.1]) by turing.freelists.org (Avenir Technologies Mail Multiplex) with ESMTP id 4DA802F2BA for ; Tue, 13 Nov 2018 11:11:28 -0500 (EST) Received: from turing.freelists.org ([127.0.0.1]) by localhost (turing.freelists.org [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id LInvba0iMu9s for ; Tue, 13 Nov 2018 11:11:28 -0500 (EST) Received: from smtpng3.m.smailru.net (smtpng3.m.smailru.net [94.100.177.149]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by turing.freelists.org (Avenir Technologies Mail Multiplex) with ESMTPS id 7D0FB2F209 for ; Tue, 13 Nov 2018 11:11:27 -0500 (EST) From: Nikita Pettik Subject: [tarantool-patches] [PATCH v2 0/4] Introduce row_count() function Date: Tue, 13 Nov 2018 19:11:19 +0300 Message-Id: Sender: tarantool-patches-bounce@freelists.org Errors-to: tarantool-patches-bounce@freelists.org Reply-To: tarantool-patches@freelists.org List-help: List-unsubscribe: List-software: Ecartis version 1.0.0 List-Id: tarantool-patches List-subscribe: List-owner: List-post: List-archive: To: tarantool-patches@freelists.org Cc: v.shpilevoy@tarantool.org, Nikita Pettik Branch: https://github.com/tarantool/tarantool/commits/np/gh-2181-rework-change-counter-v2 Issue: https://github.com/tarantool/tarantool/issues/2181 This patch-set slightly fixes behaviour of changes() function (in order to be closer to ROW_COUNT analogue from ANSI SQL), renames it row_count() and removes total_changes() function. All these changes take place according to comments in @dev mailing list. Changes in v2: Actually, it is kind of completely independent approach and it has nothing in common with first iteration (which was aimed at dealing with behaviour of total_changes() during transaction). Nikita Pettik (4): sql: don't increment row count on FK creation within CREATE TABLE sql: account REPLACE as two row changes sql: remove total_changes() function sql: rename changes() to row_count() src/box/execute.c | 2 +- src/box/sql/build.c | 3 +- src/box/sql/func.c | 34 +--------- src/box/sql/insert.c | 2 +- src/box/sql/main.c | 32 ++------- src/box/sql/sqliteInt.h | 15 +++-- src/box/sql/vdbeaux.c | 16 ++--- test/sql/row-count.result | 157 ++++++++++++++++++++++++++++++++++++++++++++ test/sql/row-count.test.lua | 54 +++++++++++++++ 9 files changed, 237 insertions(+), 78 deletions(-) create mode 100644 test/sql/row-count.result create mode 100644 test/sql/row-count.test.lua -- 2.15.1