From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from [87.239.111.99] (localhost [127.0.0.1]) by dev.tarantool.org (Postfix) with ESMTP id 86CDA6F179; Tue, 30 Jun 2026 15:27:58 +0300 (MSK) DKIM-Filter: OpenDKIM Filter v2.11.0 dev.tarantool.org 86CDA6F179 DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=tarantool.org; s=dev; t=1782822478; bh=5mGWmw3gt9PiUjFJR3k9omc5GrXuvutT8vKnskrahrI=; h=Date:To:References:In-Reply-To:Subject:List-Id:List-Unsubscribe: List-Archive:List-Post:List-Help:List-Subscribe:From:Reply-To:Cc: From; b=lnq35DnmBQ1r8iKrWAgW2+fJkcOG4/iSPSUwByJWUKoYERWqvcW3RbZUu/f/aONpV scdHN0Ptlpx+zfHULBvuIvlZ8E4p61VGrJfcrcakHlbqIP0IeCCiwGD3xLfxeWmDob n2qbaPnZK0Y17t8dbYP8yqCgPyHEA1oEuFt7V4F8= Received: from send217.i.mail.ru (send217.i.mail.ru [95.163.59.56]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested) by dev.tarantool.org (Postfix) with ESMTPS id 4A15E6F179 for ; Tue, 30 Jun 2026 15:27:57 +0300 (MSK) DKIM-Filter: OpenDKIM Filter v2.11.0 dev.tarantool.org 4A15E6F179 Received: by exim-smtp-78b8b8c574-bdnwk with esmtpa (envelope-from ) id 1weXZE-00000000BNj-17YL; Tue, 30 Jun 2026 15:27:56 +0300 Date: Tue, 30 Jun 2026 15:27:16 +0300 To: Evgeniy Temirgaleev Message-ID: References: <20260625202903.3157425-1-skaplun@tarantool.org> <1782741349.288346286@f466.i.mail.ru> <1782820111.346121703@f764.i.mail.ru> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: <1782820111.346121703@f764.i.mail.ru> X-Mailru-Src: smtp X-4EC0790: 10 X-7564579A: B8F34718100C35BD X-77F55803: 4F1203BC0FB41BD9F802F6E87846D5F6B3E271D7F7C66D9F21C484367211601C00894C459B0CD1B918EF1ADA93F460E433594132A326AF8B98D38F58D34111CCC602BE81CD1DCE67DB077C1F076B10D7 X-7FA49CB5: FF5795518A3D127A4AD6D5ED66289B5278DA827A17800CE792C68BF9CD4C0E9EEA1F7E6F0F101C67BD4B6F7A4D31EC0BCC500DACC3FED6E28638F802B75D45FF8AA50765F7900637F88016AB904663428638F802B75D45FF914D58D5BE9E6BC1A93B80C6DEB9DEE97C6FB206A91F05B2A874BEDCBAF134A82E070BE324C7D3C4D92F4A5804F85821F6B57BC7E64490618DEB871D839B73339E8FC8737B5C2249F9238D9F5226D930CC7F00164DA146DAFE8445B8C89999729449624AB7ADAF37F6B57BC7E64490611E7FA7ABCAF51C92176DF2183F8FC7C0B882963B8E9439758941B15DA834481F9449624AB7ADAF372E808ACE2090B5E14AD6D5ED66289B5278DA827A17800CE76631511D42670FFE2EB15956EA79C166A417C69337E82CC275ECD9A6C639B01B78DA827A17800CE72F88032165008D51731C566533BA786AA5CC5B56E945C8DA X-C1DE0DAB: 0D63561A33F958A52057131C32952CCC5002B1117B3ED696BCCED4587B0D0932A9DAB4B68AE4D22F823CB91A9FED034534781492E4B8EEAD9CFA8CFAC159CE19BDAD6C7F3747799A X-C8649E89: 1C3962B70DF3F0AD73CAD6646DEDE1918E10F71CB4DF9F96AB70F9BE574AE9C625B6776AC983F447FC0B9F89525902EE6F57B2FD27647F25E66C117BDB76D6595AB4F415BA5875B7F72AF92D84F0E07E04EEB268B366C1FEA619E943D333620501B4509B2C424E2EB8341EE9D5BE9A0AC484D1FA067EE28C99B9F379ECC66026205AA76F2E4693DF6536EB022892E5344C41F94D744909CECFA6C6B0C050A61A8CAF69B82BA93681CD72808BE417F3B9E0E7457915DAA85F X-D57D3AED: 3ZO7eAau8CL7WIMRKs4sN3D3tLDjz0dLbV79QFUyzQ2Ujvy7cMT6pYYqY16iZVKkSc3dCLJ7zSJH7+u4VD18S7Vl4ZUrpaVfd2+vE6kuoey4m4VkSEu53w8ahmwBjZKM/YPHZyZHvz5uv+WouB9+ObcCpyrx6l7KImUglyhkEat/+ysWwi0gdhEs0JGjl6ggRWTy1haxBpVdbIX1nthFXMZebaIdHP2ghjoIc/363UZI6Kf1ptIMVRSZSJkMhZtMwqhwSiKXTfQ= X-DA7885C5: CBE507DDF890C06AF255D290C0D534F9A66F10D9E0262C738447FF784F553A58C47220A5B4868E545B1A4C17EAA7BC4BEF2421ABFA55128DAF83EF9164C44C7E X-Mailru-Sender: 689FA8AB762F7393520AF17B8A65FDE2DC44CC3F35C82F1C860CA03FB60C37CE5DDD0FD089E12738E49D44BB4BD9522A059A1ED8796F048DB274557F927329BE89D5A3BC2B10C37545BD1C3CC395C826B4A721A3011E896F X-Mras: Ok Subject: Re: [Tarantool-patches] [PATCH luajit 2/3] dbg: introduce lj-ctype command, extend cdata dump X-BeenThere: tarantool-patches@dev.tarantool.org X-Mailman-Version: 2.1.34 Precedence: list List-Id: Tarantool development patches List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , From: Sergey Kaplun via Tarantool-patches Reply-To: Sergey Kaplun Cc: tarantool-patches@dev.tarantool.org Errors-To: tarantool-patches-bounces@dev.tarantool.org Sender: "Tarantool-patches" Evgeniy, Thanks for the answer, see my thoughts below. On 30.06.26, Evgeniy Temirgaleev wrote: > Hi, Sergey! > > LGTM. And please see my note about renaming issue. > > > > > From: Sergey Kaplun > > To: Evgeniy Temirgaleev > > Cc: tarantool-patches@dev.tarantool.org, Sergey Bronnikov > > > > Date: Monday, June 29, 2026 10:21 PM +03:00 > > > > + > > > > +def ctype_isrefarray(info): > > > > + return (info & (CTMASK_NUM | CTF_VECTOR | CTF_COMPLEX)) == \ > > > > + ctinfo(CT_ARRAY, 0) > > > > + > > > > + > > > > +def ctype_cid(info): > > > > > > > > > > Let’s put these function definitions in the ‘lj_ctype.h’ order? > > > May we group the definitions by corresponding C files also? # lj_ctype.h > > … # lj_cdata.h … # lj_xxx.c … > > > > > > Sorted as you suggested. The sorting is the following: > > * lj_ctype.h > > * lj_cdata.h -- `cdata_getptr()` > > * lj_obj.h -- `cdataptr()` > > > > Thanks! We can add a comment with file name before each block to improve readability slightly more. Feel free to ignore. I suppose that ctags or whatsoever will do the trick. Ignoring since you don't insist. > > > > > > > > > > Also, it seems, it will be easy to read to code, if it will be possible > > to distinguish between ported functions and extension itself ones. May be > > by use the ‘dbg_’ prefix for extension function names. > > > > I suppose this refactoring can be done in the separate issue. Since it > > is related to all functions. Also, the `dbg` is already used for the > > instance of the corresponding class. `dump_` prefix looks common for all > > dumpers of our extension. > > > > Agreed. And I vote for this patch. > May be it will be several documented prefixes. It will be more verbosely, but I think it will be very helpful in a long perspective for supporting the extension to quick distinguish LuaJIT-ported routine e.g. `ctype_preplit` with extension routine e.g. `cdata_val_int64`. > Can you offer some prefix name good for you now? May be we can start naming with it at this point, what do you think? For now we have several "prefixes": * `dbg.` for the debugger implementation defined helpers. * `dump_` for the dumper function of any kind (even helpers). * `LJ*` for the classes to be the entry points for our extensions. I'm not sure that ctype_preplit -> dump_ctype_preplit helps for find the original logic for this dumper from the LuaJIT source code. So, I'm open to ideas ;). I prefer if the refactoring of names will be done separately so there is no a part of the naming in this patch series and another part in the next one. At least this is inconsistent. > > -- > Best regards, > Evgeniy Temirgaleev -- Best regards, Sergey Kaplun