Tarantool development patches archive
 help / color / mirror / Atom feed
[Tarantool-patches] [PATCH v2 0/2] Return getaddrinfo() errors
 2020-07-23 14:12 UTC  (7+ messages)
` [Tarantool-patches] [PATCH v2 1/2] coio/say: fix getaddrinfo error handling on macOS

[Tarantool-patches] [PATCH] iproto: stringify IPROTO_CONFIRM, IPROTO_ROLLBACK
 2020-07-23 12:57 UTC 

[Tarantool-patches] [PATCH v2 0/5] qsync: write CONFIRM/ROLLBACK without txn engine
 2020-07-23 12:29 UTC  (8+ messages)
` [Tarantool-patches] [PATCH v2 1/7] journal: drop redundant declaration
` [Tarantool-patches] [PATCH v2 2/7] wal: bind asynchronous write completion to an entry
` [Tarantool-patches] [PATCH v2 3/7] journal: add journal_entry_create helper
` [Tarantool-patches] [PATCH v2 4/7] qsync: provide a binary form of CONFIRM/ROLLBACK entries
` [Tarantool-patches] [PATCH v2 5/7] qsync: provide a way to encode preallocated "
` [Tarantool-patches] [PATCH v2 6/7] qsync: implement direct write of CONFIRM/ROLLBACK into a journal
` [Tarantool-patches] [PATCH v2 7/7] qsync: drop no longer used xrow_encode_confirm, rollback

[Tarantool-patches] [PATCH 0/5] qsync: write confirm/rollback without txn engine
 2020-07-23 11:41 UTC  (8+ messages)
` [Tarantool-patches] [PATCH 1/5] journal: drop redundant declaration
` [Tarantool-patches] [PATCH 2/5] wal: bind asynchronous write completion to an entry
` [Tarantool-patches] [PATCH 3/5] journal: add journal_entry_create helper
` [Tarantool-patches] [PATCH 4/5] qsync: implement direct write of confirm/rollback into a journal
` [Tarantool-patches] [PATCH 5/5] qsync: fix release build

[Tarantool-patches] [PATCH 0/2] Implement LuaJIT platform metrics
 2020-07-23 10:15 UTC  (5+ messages)
` [Tarantool-patches] [PATCH 1/2] metrics: add counters for metrics interested in
` [Tarantool-patches] [PATCH 2/2] metrics: add C and Lua API
` [Tarantool-patches] [RFC] rfc: luajit metrics

[Tarantool-patches] [PATCH 0/2] Qsync flaky tests, next iteration
 2020-07-22 23:57 UTC  (3+ messages)
` [Tarantool-patches] [PATCH 1/2] test: fix flaky qsync_snapshots.test.lua again
` [Tarantool-patches] [PATCH 2/2] test: fix flaky qsync_with_anon.test.lua again

[Tarantool-patches] [PATCH 0/2] Make txn_commit() simpler
 2020-07-22 23:14 UTC  (7+ messages)
` [Tarantool-patches] [PATCH 1/2] txn_limbo: single function to confirm transactions
` [Tarantool-patches] [PATCH 2/2] txn: remove TXN_IS_DONE check from txn_commit()

[Tarantool-patches] [PATCH] stailq: provide better names for args
 2020-07-22 23:00 UTC  (2+ messages)

[Tarantool-patches] [PATCH] vinyl: rotate mem during index build on demand
 2020-07-22 22:54 UTC  (4+ messages)

[Tarantool-patches] [PATCH 0/2] Qsync crash on WAL write fail
 2020-07-22 22:27 UTC  (9+ messages)
` [Tarantool-patches] [PATCH 1/2] txn: single failure point for WAL and TX commit errors
` [Tarantool-patches] [PATCH 2/2] txn: single failure point for WAL and TX async "

[Tarantool-patches] [PATCH] lua/utils: improve luaT_newthread performance
 2020-07-22 15:12 UTC  (4+ messages)

[Tarantool-patches] [PATCH] gdb: fix the extension to be loaded with Python 2
 2020-07-22 12:46 UTC  (4+ messages)

[Tarantool-patches] [PATCH v3] lua: assert in lua_gettop() in case of negative stack size
 2020-07-22 12:05 UTC  (8+ messages)

[Tarantool-patches] [PATCH v1] gitlab-ci: setup local cleanup/checkout processes
 2020-07-22 10:39 UTC  (2+ messages)

[Tarantool-patches] [PATCH 1/1] txn: remove TXN_IS_DONE check from txn_commit()
 2020-07-22  7:39 UTC  (6+ messages)

[Tarantool-patches] [PATCH v1] gitlab-ci: set cleanup based on docker for all
 2020-07-22  6:46 UTC 

[Tarantool-patches] [PATCH 1/1] txn_limbo: use fiber_clock() instead of fiber_time()
 2020-07-21 20:26 UTC  (3+ messages)

[Tarantool-patches] [PATCH v2] lua: assert on lua_gettop() negative return value
 2020-07-21 18:19 UTC  (5+ messages)

[Tarantool-patches] [PATCH 00/19] Add static analysis of Lua code in test/ with luacheck
 2020-07-21 12:38 UTC  (25+ messages)
` [Tarantool-patches] [PATCH 02/19] Fix luacheck warnings in test/app
` [Tarantool-patches] [PATCH 03/19] Fix luacheck warnings in test/box
` [Tarantool-patches] [PATCH 04/19] Fix luacheck warnings in test/box-py
` [Tarantool-patches] [PATCH 05/19] Fix luacheck warnings in test/box-tap
` [Tarantool-patches] [PATCH 06/19] Fix luacheck warnings in test/engine
` [Tarantool-patches] [PATCH 07/19] Fix luacheck warnings in test/engine_long
` [Tarantool-patches] [PATCH 08/19] Fix luacheck warnings in test/long_run-py
` [Tarantool-patches] [PATCH 09/19] Fix luacheck warnings in test/replication
` [Tarantool-patches] [PATCH 10/19] Fix luacheck warnings in test/replication-py
` [Tarantool-patches] [PATCH 11/19] Fix luacheck warnings in test/sql
` [Tarantool-patches] [PATCH 12/19] Fix luacheck warnings in test/sql-tap
` [Tarantool-patches] [PATCH 13/19] Fix luacheck warnings in test/swim
` [Tarantool-patches] [PATCH 14/19] Fix luacheck warnings in test/vinyl
` [Tarantool-patches] [PATCH 15/19] Fix luacheck warnings in test/wal_off
` [Tarantool-patches] [PATCH 16/19] Fix luacheck warnings in test/xlog
` [Tarantool-patches] [PATCH 17/19] Fix luacheck warnings in test/xlog-py
` [Tarantool-patches] [PATCH 18/19] Add luacheck supression for luajit test
` [Tarantool-patches] [PATCH 19/19] luajit: bump new version
` [Tarantool-patches] [PATCH] test: fix warnings spotted by luacheck

[Tarantool-patches] [PATCH] lua: assert on lua_gettop() negative return value
 2020-07-21 11:05 UTC  (3+ messages)

[Tarantool-patches] [PATCH 1/3] replication: print number of txs in limbo before its clear
 2020-07-20 22:01 UTC  (6+ messages)
` [Tarantool-patches] [PATCH 2/3] replication: test clear_synchro_queue function
` [Tarantool-patches] [PATCH 3/3] replication: add test with random leaders promotion and demotion

[Tarantool-patches] [PATCH 0/2] introduce actions on leader election
 2020-07-20 21:13 UTC  (4+ messages)
` [Tarantool-patches] [PATCH 2/2] box: introduce a cfg handle to become syncro leader

[Tarantool-patches] [PATCH 1/1] tuple: turn invalid bar update into nop
 2020-07-20 19:42 UTC  (2+ messages)

[Tarantool-patches] [PATCH 0/4] qsync: continue cooking the code
 2020-07-20 19:28 UTC  (9+ messages)
` [Tarantool-patches] [PATCH 4/4] qsync: don't send negative timeouts into fiber_cond_wait_timeout
  ` [Tarantool-patches] [PATCH v2 "

[Tarantool-patches] [PATCH 0/4] Flaky qsync tests
 2020-07-20 19:23 UTC  (7+ messages)
` [Tarantool-patches] [PATCH 1/4] test: fix flaky qsync_with_anon.test.lua
` [Tarantool-patches] [PATCH 2/4] test: fix flaky qsync_advanced.test.lua
` [Tarantool-patches] [PATCH 3/4] test: fix flaky qsync_snapshots.test.lua
` [Tarantool-patches] [PATCH 4/4] test: fix flaky qsync_basic.test.lua

[Tarantool-patches] [PATCH] box: remove unnecessary bootsrap. file
 2020-07-20 13:41 UTC 

[Tarantool-patches] [PATCH] lua: do not use internal api in public headers
 2020-07-20 11:34 UTC  (2+ messages)

[Tarantool-patches] [PATCH v1] gitlab-ci: set 2.5 version for gitlab-ci jobs
 2020-07-17 17:22 UTC 

[Tarantool-patches] [PATCH v4 0/2] Unify pattern for column names
 2020-07-17 12:33 UTC  (2+ messages)

[Tarantool-patches] [PATCH v2 0/3] Merger's NULL defererence
 2020-07-17 11:28 UTC  (18+ messages)
` [Tarantool-patches] [PATCH v2 1/3] merger: fix NULL dereference when called via iproto
` [Tarantool-patches] [PATCH v2 2/3] merger: clean fiber-local Lua stack after next()
` [Tarantool-patches] [PATCH v2 3/3] lua: expose temporary Lua state for iproto calls

[Tarantool-patches] [PATCH 0/2] Msgpack wrong extension type in error message
 2020-07-17 11:27 UTC  (12+ messages)
` [Tarantool-patches] [PATCH 2/2] msgpack: fix wrong mp_ext "

[Tarantool-patches] [PATCH v1] Bump curl repository to 7.71.1 version
 2020-07-17 11:09 UTC  (5+ messages)

[Tarantool-patches] [PATCH 0/2] Qsync flaky tests, next iteration
 2020-07-17 10:56 UTC  (2+ messages)

[Tarantool-patches] [PATCH] lua: panic on lua_gettop() negative return value
 2020-07-17 10:36 UTC  (3+ messages)

[Tarantool-patches] [PATCH v1] Divide replication/mist.test.lua
 2020-07-17  9:25 UTC 

[Tarantool-patches] [PATCH 1/1] box: fixed box.info:memory()
 2020-07-17  6:38 UTC  (16+ messages)
` [Tarantool-patches] [PATCH 0/1] fix box.info:memory()

[Tarantool-patches] [PATCH v3 00/13] Transaction engine for memtx engine
 2020-07-17  6:16 UTC  (10+ messages)
` [Tarantool-patches] [PATCH v3 02/13] Check data_offset overflow in struct tuple
` [Tarantool-patches] [PATCH v3 11/13] txm: introduce txm_story
` [Tarantool-patches] [PATCH v3 13/13] tmx: use new tx manager in memtx

[Tarantool-patches] [PATCH] lua: introduce function to check that passed value is uuid
 2020-07-16 18:20 UTC 

[Tarantool-patches] [PATCH v6 00/22] sql: change implicit cast
 2020-07-16 17:28 UTC  (31+ messages)
` [Tarantool-patches] [PATCH v6 01/22] sql: change implicit cast for assignment
` [Tarantool-patches] [PATCH v6 02/22] sql: use ApplyType to check function arguments
` [Tarantool-patches] [PATCH v6 03/22] sql: check args of abs()
` [Tarantool-patches] [PATCH v6 04/22] sql: check args of avg(), sum() and total()
` [Tarantool-patches] [PATCH v6 05/22] sql: check args of char()
` [Tarantool-patches] [PATCH v6 06/22] sql: check args of length()
` [Tarantool-patches] [PATCH v6 07/22] sql: check operands of LIKE
` [Tarantool-patches] [PATCH v6 08/22] sql: check args of lower() and upper()
` [Tarantool-patches] [PATCH v6 09/22] sql: check args of position()
` [Tarantool-patches] [PATCH v6 10/22] sql: check args of randomblob()
` [Tarantool-patches] [PATCH v6 11/22] sql: check args of replace()
` [Tarantool-patches] [PATCH v6 12/22] sql: check args of round()
` [Tarantool-patches] [PATCH v6 13/22] sql: check args of soundex()
` [Tarantool-patches] [PATCH v6 14/22] sql: check args of substr()
` [Tarantool-patches] [PATCH v6 15/22] sql: check args of unicode()
` [Tarantool-patches] [PATCH v6 16/22] sql: check args of zeroblob()
` [Tarantool-patches] [PATCH v6 17/22] sql: remove unused DOUBLE to INTEGER conversion
` [Tarantool-patches] [PATCH v6 18/22] sql: add implicit cast between numbers in OP_Seek*
` [Tarantool-patches] [PATCH v6 19/22] sql: change comparison between numbers using index
` [Tarantool-patches] [PATCH v6 20/22] sql: remove implicit cast from comparison opcodes
` [Tarantool-patches] [PATCH v6 21/22] sql: fix implicit cast in opcode MustBeInt
` [Tarantool-patches] [PATCH v6 22/22] sql: remove implicit cast from MakeRecord opcode

page:  |  | latest

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox