Tarantool development patches archive
 help / color / mirror / Atom feed
[Tarantool-patches] [PATCH] vinyl: unthrottle scheduler on checkpoint
 2020-03-31 14:53 UTC  (2+ messages)

[Tarantool-patches] [PATCH v5 0/4] replication: fix local space tracking
 2020-03-31 11:24 UTC  (10+ messages)
` [Tarantool-patches] [PATCH v5 1/4] vclock: add an ability to reset individual clock components
` [Tarantool-patches] [PATCH v5 2/4] replication: hide 0-th vclock components in replication responses
` [Tarantool-patches] [PATCH v5 3/4] gc: rely on minimal vclock components instead of signatures
` [Tarantool-patches] [PATCH v5 4/4] box: start counting local space requests separately

[Tarantool-patches] [PATCH v1] gitlab-ci: implement OSX 10.14 testing on mac mini
 2020-03-31  9:10 UTC  (3+ messages)

[Tarantool-patches] [PATCH] vinyl: bump dump_generation in case scheduler doesn't catch up with DDL
 2020-03-31  0:47 UTC 

[Tarantool-patches] [PATCH v2 00/10] Stacked diagnostics
 2020-03-30 23:24 UTC  (38+ messages)
` [Tarantool-patches] [PATCH v2 01/10] box: rfc for stacked diagnostic area
` [Tarantool-patches] [PATCH v2 02/10] box: rename diag_add_error to diag_set_error
` [Tarantool-patches] [PATCH v2 03/10] test: move box.error tests to box/error.test.lua
` [Tarantool-patches] [PATCH v2 04/10] box/error: introduce box.error.set() method
` [Tarantool-patches] [PATCH v2 05/10] box/error: don't set error created via box.error.new to diag
` [Tarantool-patches] [PATCH v2 06/10] box: introduce stacked diagnostic area
` [Tarantool-patches] [PATCH v2 07/10] box: use stacked diagnostic area for functional indexes
` [Tarantool-patches] [PATCH v2 08/10] box/error: clarify purpose of reference counting in struct error
` [Tarantool-patches] [PATCH v2 09/10] iproto: refactor error encoding with mpstream
` [Tarantool-patches] [PATCH v2 10/10] iproto: support error stacked diagnostic area

[Tarantool-patches] [PATCH] fiber: abort trace recording on fiber yield
 2020-03-30 22:44 UTC 

[Tarantool-patches] [PATCH 1/1] box: export box_session_push to the public C API
 2020-03-30 21:03 UTC  (4+ messages)

[Tarantool-patches] [PATCH 0/4] Enable LuaJIT tests written in C
 2020-03-30 18:55 UTC  (10+ messages)
` [Tarantool-patches] [PATCH 1/4] luajit: bump new version
` [Tarantool-patches] [PATCH 2/4] test: adjust luajit-tap testing machinery
` [Tarantool-patches] [PATCH 3/4] test: enable luajit-tap:gh-4427-ffi-sandwich tests
` [Tarantool-patches] [PATCH 4/4] test: enable luajit-tap:lj-flush-on-trace tests

[Tarantool-patches] [PATCH] test: fix vinyl/deferred_delete failure
 2020-03-30 18:03 UTC 

[Tarantool-patches] [PATCH v1 1/1] sql: remove implicit cast for COMPARISON
 2020-03-30 16:53 UTC  (4+ messages)

[Tarantool-patches] [test-run] Add options for upgrade testing
 2020-03-30 14:48 UTC 

[Tarantool-patches] [PATCH v1] Add option to update file with reference output
 2020-03-30 14:45 UTC  (6+ messages)

[Tarantool-patches] [PATCH v1 0/3] extend packages pushing to S3 script
 2020-03-30 14:40 UTC  (5+ messages)
` [Tarantool-patches] [PATCH v1 1/3] Add metafiles cleanup routines at S3 pack script
` [Tarantool-patches] [PATCH v1 2/3] Enable script for saving packages in S3 for modules
` [Tarantool-patches] [PATCH v1 3/3] Add help instruction on 'product' option

[Tarantool-patches] [PATCH luajit 0/2] Trace abort on FFI sandwich or mode change
 2020-03-30 14:25 UTC  (11+ messages)
` [Tarantool-patches] [PATCH luajit 1/2] jit: abort trace recording and execution for C API
` [Tarantool-patches] [PATCH luajit 2/2] jit: abort trace execution on JIT mode change

[Tarantool-patches] [PATCH] Add new error injection constant ERRINJ_AUTO_UPGRADE
 2020-03-30 13:11 UTC  (2+ messages)

[Tarantool-patches] [PATCH v4 0/4] replication: fix local space tracking
 2020-03-30 12:54 UTC  (14+ messages)
` [Tarantool-patches] [PATCH v4 1/4] vclock: add an ability to reset individual clock components
` [Tarantool-patches] [PATCH v4 2/4] replication: hide 0-th vclock components in replication responses
` [Tarantool-patches] [PATCH v4 3/4] gc: rely on minimal vclock components instead of signatures
` [Tarantool-patches] [PATCH v4 4/4] box: start counting local space requests separately

[Tarantool-patches] [PATCH 0/6] Extending error functionality
 2020-03-30 10:48 UTC  (21+ messages)
` [Tarantool-patches] [PATCH 3/6] iproto: Add negotiation phase

[Tarantool-patches] [PATCH 0/4] session settings fixes
 2020-03-30  9:13 UTC  (5+ messages)
` [Tarantool-patches] [PATCH 1/4] box: replace session_settings modules with a single array
` [Tarantool-patches] [PATCH 2/4] box: add binary search for _session_settings space
` [Tarantool-patches] [PATCH 3/4] box: provide a user friendly frontend for accessing session settings
` [Tarantool-patches] [PATCH 4/4] sql: "

[Tarantool-patches] [PATCH v2 0/2] add memory leaks detection via LSAN
 2020-03-30  8:09 UTC  (7+ messages)
` [Tarantool-patches] [PATCH v2 1/2] test: use default replication connection timeout
` [Tarantool-patches] [PATCH v2 2/2] gitlab-ci: add memory leaks detection via LSAN

[Tarantool-patches] [PATCH v2 0/2] Return getaddrinfo() errors
 2020-03-29  9:25 UTC  (7+ messages)
` [Tarantool-patches] [PATCH v2 1/2] coio/say: fix getaddrinfo error handling on macOS
` [Tarantool-patches] [PATCH v2 2/2] lua: return getaddrinfo() errors

[Tarantool-patches] [PATCH v2 vshard 0/2] storage: introduce upgrade strategy
 2020-03-28 18:04 UTC  (4+ messages)
` [Tarantool-patches] [PATCH v2 vshard 1/2] "

[Tarantool-patches] [PATCH v3 0/4] replication: fix local space tracking
 2020-03-28 16:20 UTC  (11+ messages)
` [Tarantool-patches] [PATCH v3 1/4] vclock: add an ability to set individual clock components
` [Tarantool-patches] [PATCH v3 2/4] gc: rely on minimal vclock components instead of signatures
` [Tarantool-patches] [PATCH v3 4/4] box: start counting local space requests separately

[Tarantool-patches] [PATCH 0/2] fix assertion fault in SELECT * FROM "_vfunc"
 2020-03-27 23:37 UTC  (8+ messages)
` [Tarantool-patches] [PATCH 1/2] box: allow schema upgrades within a release
` [Tarantool-patches] [PATCH 2/2] sql: fix assertion fault in SELECT * FROM "_vfunc"

[Tarantool-patches] [PATCH] box: provide a user friendly frontend for accessing session settings
 2020-03-27 23:31 UTC  (4+ messages)

[Tarantool-patches] [PATCH v4 0/3] sql: fix CAST() from BLOB to INTEGER
 2020-03-27 16:54 UTC  (7+ messages)
` [Tarantool-patches] [PATCH v4 1/3] sql: fix CAST() from STRING "
` [Tarantool-patches] [PATCH v4 2/3] sql: fix implicit cast "
` [Tarantool-patches] [PATCH v4 3/3] sql: add '\0' to the BLOB when it is cast "

[Tarantool-patches] [PATCH v3 0/2] sql: fix CAST() from BLOB to INTEGER
 2020-03-27 11:30 UTC  (7+ messages)
` [Tarantool-patches] [PATCH v3 1/2] sql: fix CAST() from STRING "
` [Tarantool-patches] [PATCH v3 2/2] sql: add '\0' to the BLOB when it is cast "

[Tarantool-patches] [PATCH] box: fix formatting in session.push
 2020-03-27 10:28 UTC 

[Tarantool-patches] [PATCH v2 0/2] box: fix session.push formatting
 2020-03-27 10:26 UTC  (4+ messages)
` [Tarantool-patches] [PATCH v2 2/2] box: fix formatting in session.push

[Tarantool-patches] [PATCH v1] Splitted single access_escalation.test.lua to a set of small independent tests
 2020-03-27  9:06 UTC  (2+ messages)

[Tarantool-patches] [PATCH 0/3] box_return_mp
 2020-03-26 17:51 UTC  (5+ messages)
` [Tarantool-patches] [PATCH 2/3] box: introduce port_c
` [Tarantool-patches] [PATCH 3/3] box: introduce box_return_mp() public C function

[Tarantool-patches] [PATCH v2 0/3] fio: close unused descriptors automatically
 2020-03-26 12:56 UTC  (3+ messages)

[Tarantool-patches] [PATCH v2] test: fix OSX host setup
 2020-03-26 12:49 UTC  (10+ messages)

[Tarantool-patches] [PATCH 0/2] popen: fix unit test
 2020-03-26 11:57 UTC  (10+ messages)
` [Tarantool-patches] [PATCH 1/2] popen: do not require space for shell args
` [Tarantool-patches] [PATCH 2/2] test: unit/popen -- provide a child process
    ` [Tarantool-patches] [PATCH v2 "

[Tarantool-patches] [PATCH 0/7] Stacked diagnostics area
 2020-03-26  1:03 UTC  (12+ messages)
` [Tarantool-patches] [PATCH 3/7] box/error: don't set error created via box.error.new to diag
` [Tarantool-patches] [PATCH 5/7] box/error: clarify purpose of reference counting in struct error
` [Tarantool-patches] [PATCH 6/7] iproto: refactor error encoding with mpstream

[Tarantool-patches] [PATCH LUAROCKS v2 0/2] Move a rocks options filter from tarantoolctl to luarocks
 2020-03-25 22:28 UTC  (3+ messages)

[Tarantool-patches] [PATCH] rocks: forward options to luarocks
 2020-03-25 22:01 UTC 

[Tarantool-patches] [PATCH 0/3] Adapt luarocks for tarantoolctl
 2020-03-25 21:50 UTC  (4+ messages)
` [Tarantool-patches] [PATCH 1/3] Add the chdir option for make
` [Tarantool-patches] [PATCH 2/3] Add a black list of the tarantoolctl options
` [Tarantool-patches] [PATCH 3/3] Adapt luarocks help for the tarantoolctl

[Tarantool-patches] [PATCH v2] Split box/hash.test.lua to a set of small independent tests
 2020-03-25  9:13 UTC  (2+ messages)

page:  |  | latest

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox