Tarantool development patches archive
 help / color / mirror / Atom feed
[Tarantool-patches] [PATCH 0/3] box_return_mp
 2020-03-26 17:49 UTC  (3+ messages)
` [Tarantool-patches] [PATCH 2/3] box: introduce port_c

[Tarantool-patches] [PATCH v2 00/10] Stacked diagnostics
 2020-03-26 16:54 UTC  (25+ messages)
` [Tarantool-patches] [PATCH v2 01/10] box: rfc for stacked diagnostic area
` [Tarantool-patches] [PATCH v2 02/10] box: rename diag_add_error to diag_set_error
` [Tarantool-patches] [PATCH v2 03/10] test: move box.error tests to box/error.test.lua
` [Tarantool-patches] [PATCH v2 04/10] box/error: introduce box.error.set() method
` [Tarantool-patches] [PATCH v2 05/10] box/error: don't set error created via box.error.new to diag
` [Tarantool-patches] [PATCH v2 06/10] box: introduce stacked diagnostic area
` [Tarantool-patches] [PATCH v2 07/10] box: use stacked diagnostic area for functional indexes
` [Tarantool-patches] [PATCH v2 08/10] box/error: clarify purpose of reference counting in struct error
` [Tarantool-patches] [PATCH v2 09/10] iproto: refactor error encoding with mpstream
` [Tarantool-patches] [PATCH v2 10/10] iproto: support error stacked diagnostic area

[Tarantool-patches] [PATCH v2 vshard 0/2] storage: introduce upgrade strategy
 2020-03-26 15:46 UTC  (4+ messages)
` [Tarantool-patches] [PATCH v2 vshard 1/2] "
` [Tarantool-patches] [PATCH v2 vshard 2/2] storage: introduce vshard.storage._call()

[Tarantool-patches] [PATCH 0/6] Extending error functionality
 2020-03-26 13:31 UTC  (18+ messages)
` [Tarantool-patches] [PATCH 1/6] error: Add a Lua backtrace to error
` [Tarantool-patches] [PATCH 2/6] error: Add the custom error type
` [Tarantool-patches] [PATCH 3/6] iproto: Add negotiation phase
` [Tarantool-patches] [PATCH 4/6] error: Add extended error transfer format
` [Tarantool-patches] [PATCH 5/6] error: Add test for extended error
` [Tarantool-patches] [PATCH 6/6] error: Transmit an error through IPROTO_OK as object

[Tarantool-patches] [PATCH v2 0/3] fio: close unused descriptors automatically
 2020-03-26 12:56 UTC  (14+ messages)
` [Tarantool-patches] [PATCH v2 1/3] fiber: introduce schedule_task() internal function
` [Tarantool-patches] [PATCH v2 2/3] fio: close unused descriptors automatically

[Tarantool-patches] [PATCH v2] test: fix OSX host setup
 2020-03-26 12:49 UTC  (10+ messages)

[Tarantool-patches] [PATCH 0/2] popen: fix unit test
 2020-03-26 11:57 UTC  (11+ messages)
` [Tarantool-patches] [PATCH 1/2] popen: do not require space for shell args
` [Tarantool-patches] [PATCH 2/2] test: unit/popen -- provide a child process
    ` [Tarantool-patches] [PATCH v2 "

[Tarantool-patches] [PATCH 0/7] Stacked diagnostics area
 2020-03-26  1:03 UTC  (18+ messages)
` [Tarantool-patches] [PATCH 3/7] box/error: don't set error created via box.error.new to diag
` [Tarantool-patches] [PATCH 4/7] box: introduce stacked diagnostic area
` [Tarantool-patches] [PATCH 5/7] box/error: clarify purpose of reference counting in struct error
` [Tarantool-patches] [PATCH 6/7] iproto: refactor error encoding with mpstream
` [Tarantool-patches] [PATCH 7/7] iproto: support error stacked diagnostic area

[Tarantool-patches] [PATCH LUAROCKS v2 0/2] Move a rocks options filter from tarantoolctl to luarocks
 2020-03-25 22:28 UTC  (3+ messages)

[Tarantool-patches] [PATCH] rocks: forward options to luarocks
 2020-03-25 22:01 UTC 

[Tarantool-patches] [PATCH 0/3] Adapt luarocks for tarantoolctl
 2020-03-25 21:50 UTC  (4+ messages)
` [Tarantool-patches] [PATCH 1/3] Add the chdir option for make
` [Tarantool-patches] [PATCH 2/3] Add a black list of the tarantoolctl options
` [Tarantool-patches] [PATCH 3/3] Adapt luarocks help for the tarantoolctl

[Tarantool-patches] [PATCH 0/2] fix assertion fault in SELECT * FROM "_vfunc"
 2020-03-25 19:18 UTC  (7+ messages)
` [Tarantool-patches] [PATCH 1/2] box: allow schema upgrades within a release
` [Tarantool-patches] [PATCH 2/2] sql: fix assertion fault in SELECT * FROM "_vfunc"

[Tarantool-patches] [PATCH] box: provide a user friendly frontend for accessing session settings
 2020-03-25 18:27 UTC  (3+ messages)

[Tarantool-patches] [PATCH v3 0/2] sql: fix CAST() from BLOB to INTEGER
 2020-03-25 18:17 UTC  (6+ messages)
` [Tarantool-patches] [PATCH v3 1/2] sql: fix CAST() from STRING "
` [Tarantool-patches] [PATCH v3 2/2] sql: add '\0' to the BLOB when it is cast "

[Tarantool-patches] [PATCH v2] Split box/hash.test.lua to a set of small independent tests
 2020-03-25  9:13 UTC  (5+ messages)

[Tarantool-patches] [PATCH v1] Add option to update file with reference output
 2020-03-25  7:07 UTC  (2+ messages)

[Tarantool-patches] [PATCH vshard 0/2] vshard upgrade and _call
 2020-03-24 23:44 UTC  (14+ messages)
` [Tarantool-patches] [PATCH vshard 1/2] storage: introduce upgrade strategy
` [Tarantool-patches] [PATCH vshard 2/2] storage: introduce vshard.storage._call()

[Tarantool-patches] [PATCH] say: fix syslog format
 2020-03-24  8:52 UTC 

[Tarantool-patches] [PATCH v1] Splitted single access_escalation.test.lua to a set of small independent tests
 2020-03-24  8:12 UTC 

[Tarantool-patches] [PATCH v2 1/2] Divide box/ddl.test.lua test
 2020-03-24  8:02 UTC  (5+ messages)

[Tarantool-patches] [PATCH v1.2] evio: workaround for wsl1 so_linger assertion
 2020-03-23 23:12 UTC  (3+ messages)

[Tarantool-patches] [PATCH v3 0/4] replication: fix local space tracking
 2020-03-23 16:51 UTC  (9+ messages)
` [Tarantool-patches] [PATCH v3 1/4] vclock: add an ability to set individual clock components
` [Tarantool-patches] [PATCH v3 2/4] gc: rely on minimal vclock components instead of signatures
` [Tarantool-patches] [PATCH v3 3/4] replication: hide 0-th vclock components in replication responses
` [Tarantool-patches] [PATCH v3 4/4] box: start counting local space requests separately

[Tarantool-patches] [PATCH v1] test: fix OSX dependencies installation
 2020-03-23 15:43 UTC  (3+ messages)

[Tarantool-patches] [PATCH] Add option to specify snapshot version
 2020-03-23 15:02 UTC  (2+ messages)

[Tarantool-patches] [PATCH v1 1/1] sql: use rowid as PK of ephemeral space on INSERT
 2020-03-23 11:42 UTC  (6+ messages)

[Tarantool-patches] [PATCH] popen: add missing ev_io initialization
 2020-03-23 11:09 UTC  (4+ messages)

[Tarantool-patches] [PATCH v1] Add S3 package checker
 2020-03-23  9:04 UTC  (2+ messages)

[Tarantool-patches] [PATCH v4 00/11] Replication from memory
 2020-03-23  6:59 UTC  (3+ messages)
` [Tarantool-patches] [PATCH v4 04/11] coio: do not throw an error, minor refactoring

[Tarantool-patches] [PATCH v2] Add some cancellation guard
 2020-03-23  6:43 UTC  (4+ messages)

[Tarantool-patches] [PATCH v15 00/11] journal redesign sync and async writes
 2020-03-21 19:51 UTC  (27+ messages)
` [Tarantool-patches] [PATCH v15 02/11] box: recovery_journal -- declare it as static
` [Tarantool-patches] [PATCH v15 03/11] box/txn: move fiber_set_txn to header
` [Tarantool-patches] [PATCH v15 04/11] box/txn: rename txn_write to txn_commit_async
` [Tarantool-patches] [PATCH v15 05/11] box/txn: move setup of txn start to txn_prepare
` [Tarantool-patches] [PATCH v15 06/11] box/txn: add txn_commit_nop helper
` [Tarantool-patches] [PATCH v15 07/11] box/txn: rename txn_entry_complete_cb to txn_complete_async
` [Tarantool-patches] [PATCH v15 08/11] box/txn: unweave txn_commit from txn_commit_async
` [Tarantool-patches] [PATCH v15 09/11] box/txn: clear fiber storage right before journal write
` [Tarantool-patches] [PATCH v15 10/11] box/txn: move journal allocation into separate routine
` [Tarantool-patches] [PATCH v15 11/11] box/journal: redesign journal operations
        ` [Tarantool-patches] [PATCH v16 "

[Tarantool-patches] [PATCH] vinyl: update mem ptr in vy_build_insert_tuple() after yield
 2020-03-20 19:40 UTC  (10+ messages)

[Tarantool-patches] [PATCH] Move txn from shema to a separate module (use C API instead of FFI)
 2020-03-20 19:27 UTC  (10+ messages)

[Tarantool-patches] [PATCH v3 0/2] test: cleanup tests code
 2020-03-20 15:06 UTC  (8+ messages)
` [Tarantool-patches] [PATCH v3 1/2] "
` [Tarantool-patches] [PATCH v3 2/2] test: rename test files

[Tarantool-patches] [PATCH 0/2] box.cfg() check memtx/vinyl_memory
 2020-03-20 13:56 UTC  (2+ messages)

[Tarantool-patches] [PATCH v2 0/2] test: rename test files and cleanup it
 2020-03-20 12:39 UTC  (7+ messages)
` [Tarantool-patches] [PATCH v2 1/2] test: cleanup tests code
` [Tarantool-patches] [PATCH v2 2/2] test: rename test files

[Tarantool-patches] [PATCH v1 1/1] sql: remove implicit cast for COMPARISON
 2020-03-20 12:34 UTC 

[Tarantool-patches] [PATCH] vclock: refactor vclock map to use type uint32_t
 2020-03-20 11:15 UTC  (2+ messages)

page:  |  | latest

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox