Tarantool development patches archive
 help / color / mirror / Atom feed
[Tarantool-patches] [PATCH v1] Add S3 package checker
 2020-03-23  9:04 UTC  (2+ messages)

[Tarantool-patches] [PATCH] Add option to specify snapshot version
 2020-03-23  8:45 UTC 

[Tarantool-patches] [PATCH] popen: add missing ev_io initialization
 2020-03-23  7:24 UTC 

[Tarantool-patches] [PATCH v4 00/11] Replication from memory
 2020-03-23  6:59 UTC  (9+ messages)
` [Tarantool-patches] [PATCH v4 01/11] recovery: do not call recovery_stop_local inside recovery_delete
` [Tarantool-patches] [PATCH v4 02/11] recovery: do not throw an error
` [Tarantool-patches] [PATCH v4 03/11] coio: do not allow parallel usage of coio
` [Tarantool-patches] [PATCH v4 04/11] coio: do not throw an error, minor refactoring

[Tarantool-patches] [PATCH v2] Add some cancellation guard
 2020-03-23  6:43 UTC  (9+ messages)

[Tarantool-patches] [PATCH vshard 0/2] vshard upgrade and _call
 2020-03-23  6:42 UTC  (9+ messages)
` [Tarantool-patches] [PATCH vshard 1/2] storage: introduce upgrade strategy
` [Tarantool-patches] [PATCH vshard 2/2] storage: introduce vshard.storage._call()

[Tarantool-patches] [PATCH 0/2] fix assertion fault in SELECT * FROM "_vfunc"
 2020-03-22 19:43 UTC  (5+ messages)
` [Tarantool-patches] [PATCH 1/2] box: allow schema upgrades within a release
` [Tarantool-patches] [PATCH 2/2] sql: fix assertion fault in SELECT * FROM "_vfunc"

[Tarantool-patches] [PATCH] box: provide a user friendly frontend for accessing session settings
 2020-03-22 19:31 UTC  (2+ messages)

[Tarantool-patches] [PATCH v1.1] evio: workaround for wsl1 so_linger assertion
 2020-03-22 19:21 UTC  (9+ messages)
` [Tarantool-patches] [PATCH v1.2] "

[Tarantool-patches] [PATCH v15 00/11] journal redesign sync and async writes
 2020-03-21 19:51 UTC  (28+ messages)
` [Tarantool-patches] [PATCH v15 01/11] box: recovery_journal_create -- set journal here
` [Tarantool-patches] [PATCH v15 02/11] box: recovery_journal -- declare it as static
` [Tarantool-patches] [PATCH v15 03/11] box/txn: move fiber_set_txn to header
` [Tarantool-patches] [PATCH v15 04/11] box/txn: rename txn_write to txn_commit_async
` [Tarantool-patches] [PATCH v15 05/11] box/txn: move setup of txn start to txn_prepare
` [Tarantool-patches] [PATCH v15 06/11] box/txn: add txn_commit_nop helper
` [Tarantool-patches] [PATCH v15 07/11] box/txn: rename txn_entry_complete_cb to txn_complete_async
` [Tarantool-patches] [PATCH v15 08/11] box/txn: unweave txn_commit from txn_commit_async
` [Tarantool-patches] [PATCH v15 09/11] box/txn: clear fiber storage right before journal write
` [Tarantool-patches] [PATCH v15 10/11] box/txn: move journal allocation into separate routine
` [Tarantool-patches] [PATCH v15 11/11] box/journal: redesign journal operations
        ` [Tarantool-patches] [PATCH v16 "

[Tarantool-patches] [PATCH v2 0/3] fio: close unused descriptors automatically
 2020-03-20 21:28 UTC  (14+ messages)
` [Tarantool-patches] [PATCH v2 1/3] fiber: introduce schedule_task() internal function
` [Tarantool-patches] [PATCH v2 2/3] fio: close unused descriptors automatically
` [Tarantool-patches] [PATCH v2 3/3] swim: use fiber._internal.schedule_task() for GC

[Tarantool-patches] [PATCH] vinyl: update mem ptr in vy_build_insert_tuple() after yield
 2020-03-20 19:40 UTC  (10+ messages)

[Tarantool-patches] [PATCH] Move txn from shema to a separate module (use C API instead of FFI)
 2020-03-20 19:27 UTC  (10+ messages)

[Tarantool-patches] [PATCH v3 0/2] test: cleanup tests code
 2020-03-20 15:06 UTC  (8+ messages)
` [Tarantool-patches] [PATCH v3 1/2] "
` [Tarantool-patches] [PATCH v3 2/2] test: rename test files

[Tarantool-patches] [PATCH 0/2] box.cfg() check memtx/vinyl_memory
 2020-03-20 13:56 UTC  (5+ messages)
` [Tarantool-patches] [PATCH 1/2] box: fail in box_check_config() on bad sql cache size

[Tarantool-patches] [PATCH v2 0/2] test: rename test files and cleanup it
 2020-03-20 12:39 UTC  (7+ messages)
` [Tarantool-patches] [PATCH v2 1/2] test: cleanup tests code
` [Tarantool-patches] [PATCH v2 2/2] test: rename test files

[Tarantool-patches] [PATCH v1 1/1] sql: remove implicit cast for COMPARISON
 2020-03-20 12:34 UTC 

[Tarantool-patches] [PATCH] vclock: refactor vclock map to use type uint32_t
 2020-03-20 11:15 UTC  (5+ messages)

[Tarantool-patches] [PATCH v2] Split box/hash.test.lua to a set of small independent tests
 2020-03-20  9:20 UTC  (6+ messages)

[Tarantool-patches] [PATCH v2 1/2] Divide box/ddl.test.lua test
 2020-03-20  8:40 UTC  (4+ messages)

[Tarantool-patches] [PATCH v2 1/1] fiber: extend max fiber name length to 255
 2020-03-20  1:59 UTC  (5+ messages)

[Tarantool-patches] [PATCH v2 0/2] Fix some options of rocks module
 2020-03-19 19:19 UTC  (3+ messages)

[Tarantool-patches] [PATCH v13 00/11] box/journal: redesign sync and async writes
 2020-03-19 16:20 UTC  (17+ messages)
` [Tarantool-patches] [PATCH v13 01/11] box: recovery_journal_create -- set journal here
` [Tarantool-patches] [PATCH v13 02/11] box: recovery_journal -- declare it as static
` [Tarantool-patches] [PATCH v13 03/11] box/txn: move fiber_set_txn to header
` [Tarantool-patches] [PATCH v13 04/11] box/txn: rename txn_write to txn_commit_async
` [Tarantool-patches] [PATCH v13 05/11] box/txn: move setup of txn start to txn_prepare
` [Tarantool-patches] [PATCH v13 06/11] box/txn: add txn_commit_nop helper
` [Tarantool-patches] [PATCH v13 07/11] box/txn: rename txn_entry_complete_cb to txn_complete_async
` [Tarantool-patches] [PATCH v13 08/11] box/txn: unweave txn_commit from txn_commit_async
` [Tarantool-patches] [PATCH v13 09/11] box/txn: clear fiber storage right before journal write
` [Tarantool-patches] [PATCH v13 10/11] box/txn: move journal allocation into separate routine
` [Tarantool-patches] [PATCH v13 11/11] box/journal: redesign journal operations

[Tarantool-patches] [PATCH v2 0/5] replication: fix local space tracking
 2020-03-19 11:59 UTC  (17+ messages)
` [Tarantool-patches] [PATCH v2 1/5] box: introduce matrix clock
` [Tarantool-patches] [PATCH v2 2/5] wal: track consumer vclock and collect logs in wal thread
` [Tarantool-patches] [PATCH v2 3/5] vclock: add an ability to set individual clock components
` [Tarantool-patches] [PATCH v2 4/5] replication: hide 0-th vclock components in replication responses
` [Tarantool-patches] [PATCH v2 5/5] box: start counting local space requests separately

[Tarantool-patches] [PATCH 1/1] iproto: show real port in logs and box.info.listen
 2020-03-19 10:45 UTC  (5+ messages)

[Tarantool-patches] [PATCH] box.execute should be immutable function
 2020-03-19 10:26 UTC  (15+ messages)
` [Tarantool-patches] [PATCH] box: make box.execute() immutable
    ` [Tarantool-patches] [PATCH 1/2] box: make box.cfg idempotent function

[Tarantool-patches] [PATCH v1] Split box/hash.test.lua to a set of small independent tests
 2020-03-19 10:26 UTC  (4+ messages)

[Tarantool-patches] [PATCH LUAROCKS v2 0/2] Move a rocks options filter from tarantoolctl to luarocks
 2020-03-18 22:12 UTC  (6+ messages)
` [Tarantool-patches] [PATCH LUAROCKS v2 1/2] Add the chdir option for make
` [Tarantool-patches] [PATCH LUAROCKS v2 2/2] Add the tarantool options black list. Update help

[Tarantool-patches] [PATCH 00/10] box/journal: redesign sync and async writes
 2020-03-18 14:09 UTC  (6+ messages)
` [Tarantool-patches] [PATCH 04/10] box/txn: move setup of txn start to txn_prepare

[Tarantool-patches] [PATCH v3] box: allow to retrieve the last generated value of sequence
 2020-03-18 13:00 UTC  (10+ messages)

[Tarantool-patches] [PATCH v1] Divide box/ddl.test.lua test
 2020-03-18 10:01 UTC  (4+ messages)

[Tarantool-patches] [PATCH 0/4] box: session settings fixes
 2020-03-18 10:00 UTC  (17+ messages)
` [Tarantool-patches] [PATCH 2/4] box: add binary search for _session_settings space
` [Tarantool-patches] [PATCH 3/4] box: provide a user friendly frontend for accessing session settings
` [Tarantool-patches] [PATCH 4/4] sql: "

[Tarantool-patches] [PATCH v2 luajit 0/3] Introduce gdb extension for LuaJIT
 2020-03-17 22:46 UTC  (7+ messages)

[Tarantool-patches] [PATCH v3 0/2] add an empty body to the unprepare response
 2020-03-17 14:15 UTC  (6+ messages)
` [Tarantool-patches] [PATCH v3 2/2] iproto: "

[Tarantool-patches] [PATCH v2] iproto: add an empty body to the unprepare response
 2020-03-17  8:04 UTC  (6+ messages)

[Tarantool-patches] [PATCH v2] build: disable LUAJIT_ENABLE_PAIRSMM
 2020-03-17  7:37 UTC  (3+ messages)

page:  |  | latest

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox