LGTM

NIT:
lp$( echo $option_dist | sed 's#\.##g’ ).1.1 would be a little more readable
 
--
Oleg Koshovetc
 
 
Пятница, 20 ноября 2020, 14:57 +03:00 от Alexander Tikhonov <avtikhon@tarantool.org>:
 



-------- Пересылаемое сообщение --------
От кого: Alexander V. Tikhonov <avtikhon@tarantool.org>
Кому: Kirill Yukhin <kyukhin@tarantool.org>
Копия: Alexander V. Tikhonov <avtikhon@tarantool.org>, tarantool-patches@dev.tarantool.org
Дата: Воскресенье, 25 октября 2020, 11:37 +03:00
Тема: [PATCH v1 3/3] update_repo: correct remove routine
 
Implemented ability to remove opensuse-leap OS packages.
---
 tools/update_repo.sh | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

diff --git a/tools/update_repo.sh b/tools/update_repo.sh
index 0d39f108d..581539719 100755
--- a/tools/update_repo.sh
+++ b/tools/update_repo.sh
@@ -881,7 +881,16 @@ function remove_rpm {
     # broken update left orphan files: they are present in the
     # storage, but does not mentioned in the metadata.
     for suffix in 'x86_64' 'noarch' 'src'; do
- file="$bucket_path/$packpath/${remove}-1.${os}${option_dist}.${suffix}.rpm"
+ if [ "$os" == "opensuse-leap" ]; then
+ # Open Build Service (openSUSE) does not follow the usual
+ # approach: 'Release' is like lp152.1.1, where the first
+ # '1' is $(RELEASE) RPM spec directive value and the second
+ # '1' is the number of rebuilds.
+ os_dist="lp"`echo $option_dist | sed 's#\.##g'`".1.1"
+ else
+ os_dist="1.${os}${option_dist}"
+ fi
+ file="$bucket_path/$packpath/${remove}-${os_dist}.${suffix}.rpm"
         echo "Searching to remove: $file"
         $aws ls $file || continue
         $aws rm $file
--
2.25.1
 

 
--
Alexander Tikhonov