From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: from smtp61.i.mail.ru (smtp61.i.mail.ru [217.69.128.41]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by dev.tarantool.org (Postfix) with ESMTPS id 410DA469710 for ; Thu, 21 May 2020 14:29:57 +0300 (MSK) Date: Thu, 21 May 2020 14:29:33 +0300 From: Alexander Turenko Message-ID: <20200521112933.ps2uhwbvkeste6ze@tkn_work_nb> References: <7f8b7e281522a7d1f7a723f7756f0c4e3be86c51.1590046682.git.avtikhon@tarantool.org> MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline In-Reply-To: <7f8b7e281522a7d1f7a723f7756f0c4e3be86c51.1590046682.git.avtikhon@tarantool.org> Subject: Re: [Tarantool-patches] [PATCH v2] test: set unix sockets for iproto at core = app List-Id: Tarantool development patches List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , To: "Alexander V. Tikhonov" Cc: Oleg Piskunov , tarantool-patches@dev.tarantool.org LGTM. (But should NOT be pushed to master until I'll push test-run fix from PR #211.) Left a couple of nits, however. See below. WBR, Alexander Turenko. > 60f84cbf ('test: use unix sockets for iproto connections') Nit: We mention commits in the form 0000000000000000000000000000000000000000 ('commit message header'): full 40-digits hash and the commit message header. You'll need to carry the header when will use full commit hash and it is okay. Personally I think that short hashes lookes better when used inline within a text and that our style will recommend them sooner or later. But now it is not so. > diff --git a/test/app-tap/tarantoolctl.test.lua b/test/app-tap/tarantoolctl.test.lua > index 4d7059559..dd90c8a25 100755 > --- a/test/app-tap/tarantoolctl.test.lua > +++ b/test/app-tap/tarantoolctl.test.lua > @@ -465,12 +465,9 @@ else > local remote_path = create_script(dir, 'remote.lua', remote_code) > test_run:cmd(("create server remote with script='%s'"):format(remote_path)) > test_run:cmd("start server remote") > - local port = tonumber( > - test_run:eval("remote", > - "return require('uri').parse(box.cfg.listen).service")[1] > - ) > + local admin_socket = test_run:eval("remote", "return box.cfg.listen")[1] Nit: Admin port / socket usually refer a console port / socket. I would name the variable `listen_url` or `remote_uri`. The former is used several times across tests and also is part of `return_listen_uri` option name.