From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Date: Wed, 22 Aug 2018 15:37:23 +0300 From: Vladimir Davydov Subject: Re: [tarantool-patches] [PATCH 1/4] Introduce separate entity object types for entity privileges. Message-ID: <20180822123723.iulbl2me6zzwwynj@esperanza> References: <8730529d7aefb43da1dd5fde8f01a6b927f8430e.1534751862.git.sergepetrenko@tarantool.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <8730529d7aefb43da1dd5fde8f01a6b927f8430e.1534751862.git.sergepetrenko@tarantool.org> To: Serge Petrenko Cc: kostja@tarantool.org, tarantool-patches@freelists.org List-ID: On Mon, Aug 20, 2018 at 11:10:05AM +0300, Serge Petrenko wrote: > diff --git a/src/box/alter.cc b/src/box/alter.cc > index 3007a131d..42136b7df 100644 > --- a/src/box/alter.cc > +++ b/src/box/alter.cc > @@ -2537,10 +2537,35 @@ priv_def_create_from_tuple(struct priv_def *priv, struct tuple *tuple) > { > priv->grantor_id = tuple_field_u32_xc(tuple, BOX_PRIV_FIELD_ID); > priv->grantee_id = tuple_field_u32_xc(tuple, BOX_PRIV_FIELD_UID); > + > const char *object_type = > tuple_field_cstr_xc(tuple, BOX_PRIV_FIELD_OBJECT_TYPE); > - priv->object_id = tuple_field_u32_xc(tuple, BOX_PRIV_FIELD_OBJECT_ID); > priv->object_type = schema_object_type(object_type); > + > + const char *data = tuple_field(tuple, BOX_PRIV_FIELD_OBJECT_ID); > + if (data == NULL) { > + tnt_raise(ClientError, ER_NO_SUCH_FIELD, > + BOX_PRIV_FIELD_OBJECT_ID + TUPLE_INDEX_BASE); Nit: bad indentation, please align this line to the parenthesis. > diff --git a/src/box/lua/upgrade.lua b/src/box/lua/upgrade.lua > index 0293f6ef8..091da2dc4 100644 > --- a/src/box/lua/upgrade.lua > +++ b/src/box/lua/upgrade.lua > @@ -964,6 +964,28 @@ local function upgrade_to_1_10_0() > create_vsequence_space() > end > > +-------------------------------------------------------------------------------- > +--- Tarantool 1.10.2 > +-------------------------------------------------------------------------------- > +local function upgrade_space_priv_to_1_10_2() Let's rename this function to upgrade_priv_to_1_10_2() > + local _priv = box.space._priv > + local _vpriv = box.space._vpriv > + local f = _priv:format() Nit: please rename 'f' to 'format'. > + > + f[4].type = 'scalar' > + _priv:format(f) > + f = _vpriv:format() > + f[4].type = 'scalar' > + _vpriv:format(f) > + _priv.index.primary:alter{parts={2, 'unsigned', 3, 'string', 4, 'scalar'}} > + _vpriv.index.primary:alter{parts={2, 'unsigned', 3, 'string', 4, 'scalar'}} > + _priv.index.object:alter{parts={3, 'string', 4, 'scalar'}} > + _vpriv.index.object:alter{parts={3, 'string', 4, 'scalar'}} > +end > + > +local function upgrade_to_1_10_2() > + upgrade_space_priv_to_1_10_2() > +end