From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Date: Tue, 3 Jul 2018 15:52:41 +0300 From: Vladimir Davydov Subject: Re: [tarantool-patches] Re: [PATCH v1 1/1] lib/bitset: rename bitset structs Message-ID: <20180703125241.nqmufiqi56s4dqnv@esperanza> References: <20180703103753.o3isk2wymm73ab6f@esperanza> <2a09bc5d-8b80-d387-7ff2-2ccb4b14d2d8@tarantool.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <2a09bc5d-8b80-d387-7ff2-2ccb4b14d2d8@tarantool.org> To: Kirill Shcherbatov Cc: tarantool-patches@freelists.org List-ID: On Tue, Jul 03, 2018 at 03:24:29PM +0300, Kirill Shcherbatov wrote: > > If you're renaming struct bitset to struct tt_bitset, you should also > > rename all its methods (bitset_create => tt_bitset_create and so forth). > Ok, I've renamed all bitset structures and methods > ====================================== > > --- > src/box/memtx_bitset.c | 108 ++++++++------- > src/box/memtx_bitset.h | 2 +- > src/lib/bitset/bitset.c | 84 ++++++------ > src/lib/bitset/bitset.h | 29 ++-- > src/lib/bitset/expr.c | 28 ++-- > src/lib/bitset/expr.h | 19 +-- > src/lib/bitset/index.c | 122 ++++++++--------- > src/lib/bitset/index.h | 54 ++++---- > src/lib/bitset/iterator.c | 115 ++++++++-------- > src/lib/bitset/iterator.h | 25 ++-- > src/lib/bitset/page.c | 27 ++-- > src/lib/bitset/page.h | 71 +++++----- > test/unit/bitset_basic.c | 66 ++++----- > test/unit/bitset_index.c | 158 +++++++++++----------- > test/unit/bitset_iterator.c | 316 ++++++++++++++++++++++---------------------- > 15 files changed, 630 insertions(+), 594 deletions(-) > > diff --git a/src/box/memtx_bitset.c b/src/box/memtx_bitset.c > index 9216ed8..33c4b47 100644 > --- a/src/box/memtx_bitset.c > +++ b/src/box/memtx_bitset.c > @@ -43,7 +43,7 @@ > #ifndef OLD_GOOD_BITSET > #include "small/matras.h" > > -struct bitset_hash_entry { > +struct tt_bitset_hash_entry { I don't think you should rename any structures or functions defined in memtx_bitset.c - they don't conflict and they are not related to struct bitset.