[Tarantool-patches] [RFC] gc/xlog: delay xlog cleanup until relays are subscribed

Cyrill Gorcunov gorcunov at gmail.com
Fri Mar 19 00:31:14 MSK 2021

On Thu, Mar 18, 2021 at 09:54:12PM +0100, Vladislav Shpilevoy wrote:
> >>
> >> Then it should have 'replication_' prefix, not 'wal_'. Because
> >> it is ignored if replicas connect before the timeout expires.
> > 
> > Replication is one of the reason while main gamer is "wal"
> > here. In the series I sent recently I named it "wal_cleanup_delay".
> > In future we might introduce some topology detector as you've
> > been suggesting and better to not stick to "replication"
> > prefix I think.
> The thing you said is just another argument for it having 'replication'
> prefix. Because topology also is not about WAL.

Topology is anoter _reason_ to defer wal cleanup, and there might
be other reasons unrelated to replications at all. On the other
hands I see what you mean and won't insist. Should I name it
replication_cleanup_delay then?

More information about the Tarantool-patches mailing list