[Tarantool-patches] [PATCH v12 5/8] module_cache: rename calls to ref in module structure

Cyrill Gorcunov gorcunov at gmail.com
Mon Jan 25 13:29:39 MSK 2021

On Sun, Jan 24, 2021 at 05:27:35PM +0100, Vladislav Shpilevoy wrote:
> Thanks for the patch!
> Why isn't it in the third commit ("improve naming")?

Because I wanna separate function descriptor changes from
module refs. They are serving different purposes and moreover
the refs patch changes the element type.

> > -	module->calls = 0;
> > +	module->ref = 0;
> I propose to be consistent with the other code and
> call it 'refs' instead of 'ref' (see struct error, struct tuple,
> struct tuple_format).


More information about the Tarantool-patches mailing list