[Tarantool-patches] [PATCH v12 3/8] module_cache: improve naming
v.shpilevoy at tarantool.org
Sun Jan 24 19:27:12 MSK 2021
Thanks for the patch!
Very dubious commit. To me the old and new names look the same.
'func_name' was even better than 'func_name_desc'. At least
because it was shorter, and 'desc' does not add any more meaning.
On 18.01.2021 21:35, Cyrill Gorcunov via Tarantool-patches wrote:
> - rename func_name to func_name_desc because
> it is not just a name but rather a name descriptor
> which includes symbol address
I don't see any address in it. Only name tokens.
> - rename func_split_name to parse_func_name because
> the action of splitting name to parts is not what
> the function about, the function parses specification
> to fetch a descriptor
> Part-of #4642
> Signed-off-by: Cyrill Gorcunov <gorcunov at gmail.com>
More information about the Tarantool-patches