[Tarantool-patches] [PATCH v3 10/10] box.ctl: rename clear_synchro_queue to promote
Vladislav Shpilevoy
v.shpilevoy at tarantool.org
Fri Apr 16 02:31:20 MSK 2021
Thanks for the patch!
> diff --git a/test/replication/election_basic.result b/test/replication/election_basic.result
> index d5320b3ff..78c911245 100644
> --- a/test/replication/election_basic.result
> +++ b/test/replication/election_basic.result
> @@ -108,6 +108,31 @@ assert(box.info.election.leader == box.info.id)
> | - true
> | ...
>
> +-- Manual election mode. A voter most of the time, a leader once
> +-- `box.ctl.promote()` is called.
> +box.cfg{election_mode = 'manual'}
> + | ---
> + | ...
> +
> +assert(box.info.election.state == 'follower')
> + | ---
> + | - true
> + | ...
> +term = box.info.election.term
> + | ---
> + | ...
> +box.ctl.promote()
> + | ---
> + | ...
> +assert(box.info.election.state == 'leader')
> + | ---
> + | - error: assertion failed!
> + | ...
> +assert(box.info.election.term > term)
> + | ---
> + | - error: assertion failed!
Hm. Shouldn't these assertions pass?
More information about the Tarantool-patches
mailing list