[Tarantool-patches] [PATCH 10/11] relay: use verbose names for fibers
gorcunov at gmail.com
Fri Nov 13 13:28:46 MSK 2020
On Fri, Nov 13, 2020 at 01:17:29PM +0300, Serge Petrenko wrote:
> 12.11.2020 22:51, Cyrill Gorcunov пишет:
> > Usually we use _f postfix for fiber's loop functions
> > and using same postfix for the fiber instance itself
> > looks inconsistent.
> > Same time if we grep for "struct fibers" we see a number
> > of places where fiber instances are postfixed with _fiber.
> > Thus lets make the same in relay fiber code:
> > - use explicit reader_fiber name for a reader
> > - use relay_fiber name for the joint relay fiber
> > which depends on the reader, moreover this explicit
> > name allows to note that the reader cancels the bound
> > fiber if error happens.
> Applier also has incosistent naming. applier->reader and applier->writer.
> Maybe apply the same naming for relay? Make relay_f relay_writer.
> And reader_fiber -> relay_reader. It looks better in my opinion.
Yeah, I though of this as well. Lets drop this patch. Actually I
suspect we gonna withdraw the whole series, except the last patch
where we fix a real bug in say_info for raft. Up to you guys.
More information about the Tarantool-patches