[Tarantool-patches] [PATCH 00/11] qsync: code refactoring
Cyrill Gorcunov
gorcunov at gmail.com
Thu Nov 12 22:51:10 MSK 2020
Guys, while I'm working on #5435 and trying to figure out
how to implement it I need to read a lot of code so here
are some patches which I guess make code more readable.
Please take a look and say what you think. We can easily
ignore the whole set.
branch gorcunov/gh-5435-clear_synchro_queue
Cyrill Gorcunov (11):
build: add more ignore paths for tags target
vclock: vclock_get - drop misleading masking
vclock: vclock_inc -- add assert() to catch overflow
txn: txn_commit_async -- drop redundant variable
qsync: rename txn_limbo::instance_id to owner_id
qsync: txn_limbo_append -- use owner_id in argument name
qsync: move limbo owner transition into separate helper
qsync: txn_limbo_wait_confirm -- refactor code a bit
qsync: drop redundant type convention
relay: use verbose names for fibers
raft: drop redundant argument
CMakeLists.txt | 6 ++
src/box/box.cc | 2 +-
src/box/raft.c | 2 +-
src/box/relay.cc | 17 ++---
src/box/txn.c | 13 ++--
src/box/txn_limbo.c | 126 ++++++++++++++++++---------------
src/box/txn_limbo.h | 4 +-
src/lib/vclock/vclock.h | 7 +-
test/unit/snap_quorum_delay.cc | 2 +-
9 files changed, 98 insertions(+), 81 deletions(-)
base-commit: 5d2962244247707c7298a59de0bd4628091dda96
--
2.26.2
More information about the Tarantool-patches
mailing list