[Tarantool-patches] [RAFT 07/10] [tosquash] raft: rename curr_leader to leader

Serge Petrenko sergepetrenko at tarantool.org
Wed Aug 26 10:52:39 MSK 2020


From: Vladislav Shpilevoy <v.shpilevoy at tarantool.org>

Because it will be consistent with 'vote', which is not
'curr_vote'.
---
 src/box/raft.c | 2 +-
 src/box/raft.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/box/raft.c b/src/box/raft.c
index 1d25459e9..714a1518a 100644
--- a/src/box/raft.c
+++ b/src/box/raft.c
@@ -40,7 +40,7 @@
 struct raft raft = {
 	.term = 0,
 	.vote = 0,
-	.curr_leader = 0,
+	.leader = 0,
 	.state = RAFT_STATE_NONE,
 };
 
diff --git a/src/box/raft.h b/src/box/raft.h
index c95a51873..927aa8f5f 100644
--- a/src/box/raft.h
+++ b/src/box/raft.h
@@ -46,7 +46,7 @@ enum raft_state {
 struct raft {
 	uint64_t term;
 	uint32_t vote;
-	uint32_t curr_leader;
+	uint32_t leader;
 	enum raft_state state;
 };
 
-- 
2.20.1 (Apple Git-117)



More information about the Tarantool-patches mailing list