[tarantool-patches] Re: [PATCH 2/5] box/console: Add explicit output EOS mapping
gorcunov at gmail.com
Tue Sep 3 11:32:14 MSK 2019
On Tue, Sep 03, 2019 at 11:27:25AM +0300, Konstantin Osipov wrote:
> > +local LUA_TERM = ';'
> term is a "terminal", not "terminator", usually. Why not call them
We simply already had
YAML_TERM = '\n...\n'
in this file, so I tried to follow naming scheme. I don't mind
> EOF or EOS? Why did you call the constant _TERM and the array
> _eos? Why assign different names to the same thing?
Well, one of the reason is that I tried to minimize changes, but
I agree that putting everything into one place would be better.
> > + return serpent.line(..., serpent_opts) .. output_eos["lua"]
> Why put them in a table, given you never access them by a variable
because we might extend this table with time when say add sql
formatting and etc.
More information about the Tarantool-patches