[Tarantool-patches] [PATCH 0/2] JSON update pre-preparation
v.shpilevoy at tarantool.org
Sat Oct 26 01:53:47 MSK 2019
The patchset is a preparation for the JSON update preparation.
The main commit is the second one. It renames internals of
tuple_update.c from update_* to xrow_update_*.
Why it is done - see the commit message.
After we decide on naming of update structures and functions, I
will rebase the main JSON preparation patch
(gerold103/gh-1261-update-json-preparation-3) on new names.
This patchset is actually an RFC, because I don't like
xrow_update_ prefix. It is bulky, too long, and most of the names,
having it, look unclear.
I would like to either keep update_ prefix, or use xupdate_ - both
are better than xrow_update_, IMO. But actually I don't really
care already, so I will name it whatever helps to push it.
Vladislav Shpilevoy (2):
rope: fix rope name template
tuple: rename update to xrow_update in tuple_update.c
src/box/tuple_update.c | 610 ++++++++++++++++++++++-------------------
src/lib/salad/rope.h | 18 +-
2 files changed, 345 insertions(+), 283 deletions(-)
2.21.0 (Apple Git-122)
More information about the Tarantool-patches