[Tarantool-patches] [PATCH 0/3] JSON preparation part 5

Vladislav Shpilevoy v.shpilevoy at tarantool.org
Fri Nov 1 02:43:04 MSK 2019


The patchset is a fifth part of preparations to JSON updates of a tuple. It
reorganizes code. Before the path there was one huge file implementing xrow
update. Soon amount of the code will be much larger, and a new code structure
was needed to be able to maintain it. Now xrow update implementation consists of
several files. One file for general update functions and structures, one file
for top-level API used by other tarantool code, and one file per each
non-trivial type of xrow field update.

By the idea, each xrow_update_<type>.c will implement update of one field types
such as array, bar, map, route. It allows to make these implementations
independent and easy to support.

Branch: http://github.com/tarantool/tarantool/tree/gerold103/gh-1261-update-json-preparation-5
Issue: https://github.com/tarantool/tarantool/issues/1261

Vladislav Shpilevoy (3):
  tuple: move tuple_update into xrow_update/ folder
  tuple: rename tuple_update_* to xrow_update_*
  tuple: rework updates to improve code extendibility

 src/box/CMakeLists.txt                        |    4 +-
 src/box/lua/tuple.c                           |    9 +-
 src/box/memtx_space.c                         |   26 +-
 src/box/space.c                               |   30 +-
 src/box/tuple.c                               |   11 +-
 src/box/tuple.h                               |    2 +-
 src/box/tuple_update.c                        | 1520 -----------------
 src/box/vinyl.c                               |   22 +-
 src/box/vy_upsert.c                           |   14 +-
 src/box/xrow_update/xrow_update.c             |  499 ++++++
 .../xrow_update.h}                            |   36 +-
 src/box/xrow_update/xrow_update_array.c       |  302 ++++
 src/box/xrow_update/xrow_update_field.c       |  665 ++++++++
 src/box/xrow_update/xrow_update_field.h       |  442 +++++
 test/box/tuple.result                         |    4 +-
 test/unit/column_mask.c                       |    8 +-
 16 files changed, 1991 insertions(+), 1603 deletions(-)
 delete mode 100644 src/box/tuple_update.c
 create mode 100644 src/box/xrow_update/xrow_update.c
 rename src/box/{tuple_update.h => xrow_update/xrow_update.h} (70%)
 create mode 100644 src/box/xrow_update/xrow_update_array.c
 create mode 100644 src/box/xrow_update/xrow_update_field.c
 create mode 100644 src/box/xrow_update/xrow_update_field.h

-- 
2.21.0 (Apple Git-122.2)



More information about the Tarantool-patches mailing list