[tarantool-patches] Re: [PATCH 1/1] buffer: port static allocator to Lua

Konstantin Osipov kostja at tarantool.org
Sat May 18 22:12:24 MSK 2019


* Vladislav Shpilevoy <v.shpilevoy at tarantool.org> [19/05/15 16:34]:

1) scalar looks clearly as a separate patch. while I like the idea
   I don't appreciate the urgency and a huge patch.

2) The static alloc patch is OK to push

3) Since you care about performance so much, I don't understand
   why you do concat (..) in Lua static alloc. Did you check it's
   a compile-time, not a run-time concat? 
> +    if ffi.C.EVP_CipherUpdate(self.ctx, wpos, scalar.ai, input, input:len()) ~= 1 then

I don't understand, if you need a scalar and an array of scalars,
and you have scalar and scalar_array variables, why would you ever
use an array in scalar? Wouldn't it be better to have two unions
instead of one for the sake of clarity?


-- 
Konstantin Osipov, Moscow, Russia, +7 903 626 22 32




More information about the Tarantool-patches mailing list