[tarantool-patches] [PATCH 0/2] sql: add better coll. determination & position func.

Ivan Koptelov ivan.koptelov at tarantool.org
Wed Mar 20 14:11:39 MSK 2019


There are two patches in this series. First one enhances
collation determination for function arguments (e.g. for cases,
when function arguments have different collations). Second one
renames instr() to position() and swaps arguments order. Also
after the second patch both arguments must have the same type,
which should be either TEXT or BLOB.

Branch https://github.com/tarantool/tarantool/tree/sudobobo/gh-3933-add-position-func
Issue https://github.com/tarantool/tarantool/issues/3933

Ivan Koptelov (2):
  sql: add better collation determination in functions
  sql: rename instr to position & add collation usage

 src/box/sql/expr.c             |  65 ++-
 src/box/sql/func.c             | 157 ++++--
 src/box/sql/sqlInt.h           |   8 +-
 src/box/sql/vdbeInt.h          |   9 +
 test/sql-tap/func.test.lua     |  10 +-
 test/sql-tap/func5.test.lua    |   4 +-
 test/sql-tap/instr.test.lua    | 706 -------------------------
 test/sql-tap/position.test.lua | 905 +++++++++++++++++++++++++++++++++
 test/sql-tap/with1.test.lua    |   4 +-
 9 files changed, 1106 insertions(+), 762 deletions(-)
 delete mode 100755 test/sql-tap/instr.test.lua
 create mode 100755 test/sql-tap/position.test.lua

-- 
2.20.1





More information about the Tarantool-patches mailing list