[PATCH 1/2] lib/core/fiber: Rename stack_direction to stack_growsdown

Cyrill Gorcunov gorcunov at gmail.com
Wed Mar 27 12:48:49 MSK 2019


On Wed, Mar 27, 2019 at 12:35:10PM +0300, Vladimir Davydov wrote:
> >  enum {
> >  	/* The minimum allowable fiber stack size in bytes */
> > @@ -808,7 +808,7 @@ fiber_stack_recycle(struct fiber *fiber)
> >  	 * it anyway.
> >  	 */
> >  	void *start, *end;
> > -	if (stack_direction < 0) {
> > +	if (stack_growsdown) {
> 
> TBO I like stack_direction more as it's looks symmetrical, so to say.

Symmetrical with what? :)

> I'd refrain from changing this if there's no other reason rather than
> personal taste.

It is not personal taste but rather a common naming (mman syscall).
Though I don't insist.



More information about the Tarantool-patches mailing list