[tarantool-patches] Re: [PATCH] net.box: ignore absence of _vcollation

Kirill Yukhin kyukhin at tarantool.org
Fri Jul 12 12:55:49 MSK 2019


Hello,

On 08 Jul 15:13, Roman Khabibov wrote:
> Ignore error about absence of _vcollation, when a client connects
> to a server of old Tarantool versions, where this space does not
> exist.
> 
> Closes #4307
> ---
> Branch: https://github.com/tarantool/tarantool/tree/romanhabibov/gh-4307-vcoll
> Issue: https://github.com/tarantool/tarantool/issues/4307

Add a regression test please.

> 
>  src/box/lua/net_box.lua | 33 +++++++++++++++++++++++++--------
>  1 file changed, 25 insertions(+), 8 deletions(-)
> 
> diff --git a/src/box/lua/net_box.lua b/src/box/lua/net_box.lua
> index 2892bb3d3..723e63045 100644
> --- a/src/box/lua/net_box.lua
> +++ b/src/box/lua/net_box.lua
> @@ -761,6 +761,11 @@ local function create_transport(host, port, user, password, callback,
>                  if status ~= 0 then
>                      local body
>                      body, body_end = decode(body_rpos)
> +                    local err_msg = 'Space \'277\' does not exist'

Space 277? Seriously? This code handles not only collations request.
Should be more generic, IMHO.

> @@ -1270,16 +1275,28 @@ function remote_methods:_install_schema(schema_version, spaces, indices,
>                  local pktype = index[PARTS][k][2] or index[PARTS][k].type
>                  local pkfield = index[PARTS][k][1] or index[PARTS][k].field
>                  local pkcollation = nil
> -                if pkcollationid ~= nil then
> +                if pkcollationid ~= nil and collations ~= nil then
>                      pkcollation = collations[pkcollationid + 1][2]
>                  end
>  
> -                local pk = {
> -                    type = pktype,
> -                    fieldno = pkfield + 1,
> -                    collation = pkcollation,
> -                    is_nullable = pknullable
> -                }
> +                local pk
> +                if collations ~= nil then
> +                    pk = {
> +                        type = pktype,
> +                        fieldno = pkfield + 1,
> +                        collation = pkcollation,
> +                        is_nullable = pknullable
> +                    }
> +                else
> +                    pk = {
> +                        type = pktype,
> +                        fieldno = pkfield + 1,
> +                        collation_id = pkcollationid,
> +                        is_nullable = pknullable
> +                    }
> +                end

IMHO, it'd be better to not duplicate code and put actual difference
under if-then-else hammock.

--
Regards, Kirill Yukhin




More information about the Tarantool-patches mailing list