[tarantool-patches] Re: [PATCH v1 1/4] box: rename space->opts checks to checks_ast

Konstantin Osipov kostja at tarantool.org
Fri Jan 18 21:00:52 MSK 2019

* Kirill Shcherbatov <kshcherbatov at tarantool.org> [19/01/10 23:12]:
> The checks field of space_opts object renamed to checks_ast to avoid a
> confusion due to introduction of a new object sql_check, representing
> precompiled VDBE program to execute.

Please use name check_constraint_expr 

A common abbreviation for foreign key constraint is fk, check
constarint - ck, not null - nn, so an alternative family of names
would be fk_constraint, ck_constraint, nn_constraint. Feel free to
use it if you like a bit shorter form.

> +	if (def->opts.checks_ast != NULL &&
> +	    sql_checks_resolve_space_def_reference(def->opts.checks_ast,

Please name the module 'check_constraint' or ck_constraint, and rename all the
functions accordingly.

Konstantin Osipov, Moscow, Russia, +7 903 626 22 32
http://tarantool.io - www.twitter.com/kostja_osipov

More information about the Tarantool-patches mailing list