[Tarantool-patches] [PATCH v3 00/20] sql: prepared statements
Kirill Yukhin
kyukhin at tarantool.org
Tue Dec 31 11:39:44 MSK 2019
Hello,
On 20 дек 15:47, Nikita Pettik wrote:
> Branch: https://github.com/tarantool/tarantool/tree/np/gh-2592-prepared-statements-v3
> Issue: https://github.com/tarantool/tarantool/issues/2592
>
> V1: https://lists.tarantool.org/pipermail/tarantool-patches/2019-November/012274.html
> V2: https://lists.tarantool.org/pipermail/tarantool-patches/2019-November/012496.html
>
> Changes in V3 (requested by server team):
>
> - Now there's no eviction policy, so statements reside in 'cache'
> until explicit deallocation via 'unprepare' call or session's
> disconect;
> - instead of string ids, now we use numeric ids which correspond
> to value of hash function applied to the string containing original
> SQL request;
> - in accordance with previous point, 'unprepare' support has been returned;
> - since there's no eviction policy, disconnect event may turn out to
> be expensive (in terms of deallocating all related to the session
> prepared statements). To remove possible spikes in workload, we
> maintain GC queue and reference counters for prepared statements.
> When all sessions (previously refed statement) unref it, statement
> gets into GC queue. In case of prepared statements holder is out
> of memory, GC process is launched: all statements in queue are
> deallocated;
> - to track available in scope of session prepared statements, we
> also maintain session-local map containing statement's IDs
> allocated in this session.
>
> Nikita Pettik (20):
> sql: remove sql_prepare_v2()
> sql: refactor sql_prepare() and sqlPrepare()
> sql: move sql_prepare() declaration to box/execute.h
> sql: rename sqlPrepare() to sql_stmt_compile()
> sql: rename sql_finalize() to sql_stmt_finalize()
> sql: rename sql_reset() to sql_stmt_reset()
> sql: move sql_stmt_finalize() to execute.h
> port: increase padding of struct port
> port: add result set format and request type to port_sql
> sql: resurrect sql_bind_parameter_count() function
> sql: resurrect sql_bind_parameter_name()
> sql: add sql_stmt_schema_version()
> sql: introduce sql_stmt_sizeof() function
> box: increment schema_version on ddl operations
> sql: introduce sql_stmt_query_str() method
> sql: move sql_stmt_busy() declaration to box/execute.h
> sql: introduce holder for prepared statemets
> box: introduce prepared statements
> netbox: introduce prepared statements
> sql: add cache statistics to box.info
I've checked your patchset into master.
--
Regards, Kirill Yukhin
More information about the Tarantool-patches
mailing list