[tarantool-patches] Re: [PATCH v1 1/1] Implement mp_stack_top for mp_stack class

Kirill Shcherbatov kshcherbatov at tarantool.org
Wed Apr 3 18:16:25 MSK 2019


> or something like that. BTW, if you agree, let's also rename 'curr' to
> 'idx' or 'index' - 'curr' looks kinda ugly and since now we are going to
> access it directly, we'd better rename it IMO.
> 
> What do you think?

I am not shure that it is good concept. Consider a part of MP_PRINT macro

	while (!mp_stack_is_empty(&stack)) {
		struct mp_frame *frame = mp_stack_top(&stack);
		enum mp_type type = frame->type;
		bool stop = !mp_frame_advance(frame);
		if (frame->idx == 0 || frame->count == 0)
			PRINTF(type == MP_ARRAY ? "[" : "{");
		if (stop) {
			PRINTF(type == MP_ARRAY ? "]" : "}");
			mp_stack_pop(&stack);
			continue;
		} else if (frame->idx != 0) {
			PRINTF(type == MP_MAP && frame->idx % 2 == 1 ? ": " : ", ");
		}
		goto next;
	}

To my opinion, the code got worse.



More information about the Tarantool-patches mailing list