[PATCH v3 4/7] lua: add non-recursive msgpack decoding functions

Vladimir Davydov vdavydov.dev at gmail.com
Tue Apr 30 16:03:17 MSK 2019


On Wed, Apr 10, 2019 at 06:21:22PM +0300, Alexander Turenko wrote:
> Needed for #3276.
> 
> @TarantoolBot document
> Title: Non-recursive msgpack decoding functions
> 
> Contracts:
> 
> ```
> msgpack.decode_array(buf.rpos, buf:size()) -> arr_len, new_rpos
> msgpack.decode_map(buf.rpos, buf:size()) -> map_len, new_rpos
> ```

Let's rename to decode_array_header and decode_map_header, as agreed
with Kostja. Other than that looks good to me.



More information about the Tarantool-patches mailing list