[PATCH v1 1/1] Implement mp_stack_top for mp_stack class

Vladimir Davydov vdavydov.dev at gmail.com
Wed Apr 3 15:12:02 MSK 2019


On Tue, Apr 02, 2019 at 06:49:57PM +0300, Kirill Shcherbatov wrote:
> Introduced a new mp_stack_top method for mp_stack class to
> return the pointer to a top frame of the stack.
> 
> This is required in scope of multikey indexes to keep a pointer
> to a multikey frame and extract currently processed item index
> of this frame later.
> 
> Needed for https://github.com/tarantool/tarantool/issues/1257
> ---
> https://github.com/tarantool/msgpuck/tree/kshch/gh-1257-new-mpstacktop-method
> https://github.com/tarantool/tarantool/issues/1257
> 
>  msgpuck.h | 20 +++++++++++++++++---
>  1 file changed, 17 insertions(+), 3 deletions(-)
> 
> diff --git a/msgpuck.h b/msgpuck.h
> index eab1339..c91d5d1 100644
> --- a/msgpuck.h
> +++ b/msgpuck.h
> @@ -1278,6 +1278,14 @@ mp_stack_is_empty(struct mp_stack *stack);
>  MP_PROTO bool
>  mp_stack_is_full(struct mp_stack *stack);
>  
> +/**
> + * \brief Return the top mp_stack \a stack frame.
> + * \param stack - the pointer to a mp_stack to operate with.
> + * \pre mp_stack_is_empty(stack) == false
> + */
> +MP_PROTO struct mp_frame *
> +mp_stack_top(struct mp_stack *stack);

Since we now have mp_stack_top, I think we should drop mp_stack_count
and mp_stack_type, otherwise there are two equally correct ways to do
the same thing, which is confusing:

	frame = mp_stack_top(stack);
	return frame->type

or

	return mp_stack_type(stack);

Similarly, I think we should rework mp_stack_advance so that it works
with mp_frame rather than stack and returns true/false rather than the
frame index. In other words, change

	int idx = mp_stack_advance(stack);
	if (idx < 0) {
		mp_stack_pop(stack);
		continue;
	}

to

	struct mp_frame *frame = mp_stack_frame(stack);
	if (!mp_frame_advance(frame)) {
		mp_stack_pop(stack);
		continue;
	}
	int idx = frame->curr;

or something like that. BTW, if you agree, let's also rename 'curr' to
'idx' or 'index' - 'curr' looks kinda ugly and since now we are going to
access it directly, we'd better rename it IMO.

What do you think?



More information about the Tarantool-patches mailing list