[tarantool-patches] Re: [PATCH] box: add tuple:size function
kostja at tarantool.org
Thu Oct 18 21:11:31 MSK 2018
* Alexander Turenko <alexander.turenko at tarantool.org> [18/10/17 18:53]:
> On Wed, Oct 17, 2018 at 06:29:49PM +0300, Konstantin Osipov wrote:
> > * Alexander Turenko <alexander.turenko at tarantool.org> [18/10/17 10:45]:
> > > Are tuple.bsize and box_tuple_bsize() subjects to change or it is only
> > > about the Lua part?
> > tuple.bsize is used internally, so I don't think you should change
> > it. But it's better to rename it to msgpack_size or something like
> > that to avoid ambiguity.
> > box_tuple_bsize() should be ok to change.
> So should I use tuple.bsize in my current WIP patch (merger) and don't
> use box_tuple_bsize() and things will not become broken in the future?
No, I suggested to rename tuple.bsize to tuple.msgpack-size.
Direct access to struct tuple members from modules should be
> BTW, I wonder why such simple public accessor function as
> box_tuple_bsize() is not defined in the header file to allow inlining?
Since it's part of the plugin api I guess.
Konstantin Osipov, Moscow, Russia, +7 903 626 22 32
http://tarantool.io - www.twitter.com/kostja_osipov
More information about the Tarantool-patches