[tarantool-patches] [PATCH v2 0/4] Introduce row_count() function

Nikita Pettik korablev at tarantool.org
Tue Nov 13 19:11:19 MSK 2018


Branch: https://github.com/tarantool/tarantool/commits/np/gh-2181-rework-change-counter-v2
Issue: https://github.com/tarantool/tarantool/issues/2181

This patch-set slightly fixes behaviour of changes() function (in
order to be closer to ROW_COUNT analogue from ANSI SQL), renames
it row_count() and removes total_changes() function.

All these changes take place according to comments in @dev
mailing list.

Changes in v2:

Actually, it is kind of completely independent approach and it has
nothing in common with first iteration (which was aimed at dealing
with behaviour of total_changes() during transaction).

Nikita Pettik (4):
  sql: don't increment row count on FK creation within CREATE TABLE
  sql: account REPLACE as two row changes
  sql: remove total_changes() function
  sql: rename changes() to row_count()

 src/box/execute.c           |   2 +-
 src/box/sql/build.c         |   3 +-
 src/box/sql/func.c          |  34 +---------
 src/box/sql/insert.c        |   2 +-
 src/box/sql/main.c          |  32 ++-------
 src/box/sql/sqliteInt.h     |  15 +++--
 src/box/sql/vdbeaux.c       |  16 ++---
 test/sql/row-count.result   | 157 ++++++++++++++++++++++++++++++++++++++++++++
 test/sql/row-count.test.lua |  54 +++++++++++++++
 9 files changed, 237 insertions(+), 78 deletions(-)
 create mode 100644 test/sql/row-count.result
 create mode 100644 test/sql/row-count.test.lua

-- 
2.15.1





More information about the Tarantool-patches mailing list