[tarantool-patches] Re: [PATCH 2/4] sql: remove unused error codes, use enum instead of defines

Vladislav Shpilevoy v.shpilevoy at tarantool.org
Wed Apr 4 13:26:07 MSK 2018

> I do like move to enum, but what about removing this obsolete ’SQLITE’ prefix?
> Let it be just ’SQL_’. Moreover, some error seems to be SQLite specific.
> Great time to remove them, isn’t it?
> If you don’t want or don’t have time for this boring routine, you can create issue
> with ‘good first issue’ label.
I am afraid that a diff will be huge, if a rename SQLITE_OK, for 
example. Lets do it later, when more
source code and error codes will be removed.

Please, review the huge diff below very carefully. I could make a 
mistake here.

diff --git a/src/box/sql/vdbeInt.h b/src/box/sql/vdbeInt.h
index f8f4e566b..6ea8c91d7 100644
--- a/src/box/sql/vdbeInt.h
+++ b/src/box/sql/vdbeInt.h
@@ -442,7 +442,6 @@ struct Vdbe {
      int nScan;        /* Entries in aScan[] */
      ScanStatus *aScan;    /* Scan definitions for 
sqlite3_stmt_scanstatus() */


More information about the Tarantool-patches mailing list