[tarantool-patches] Re: [PATCH 1/2] sql: remove obsolete SQLite routine

n.pettik korablev at tarantool.org
Thu Apr 5 15:13:19 MSK 2018


> On 5 Apr 2018, at 14:16, Vladislav Shpilevoy <v.shpilevoy at tarantool.org> wrote:
> 
> 
>>> Same about checking sqlite3HashFind results. And if it is
>>> possible with not huge diff, can you please rename sqlite3HashFind to sql_hash_find ?
>> 
>> Is it worth doing? It is going to disappear soon.
> Ok, then lets leave as is.
>> @@ -1146,7 +1147,7 @@ analyzeTable(Parse * pParse, Table * pTab, Index * pOnlyIdx)
>> int iStatCur;
>> assert(pTab != 0);
>> -sql_set_multi_write(pParse, 0);
>> +sql_set_multi_write(pParse, true);
> 1. Typo? 0 != true.

Typo. Fixed on branch:

 -       sql_set_multi_write(pParse, true);
+       sql_set_multi_write(pParse, false);

>> @@ -1769,9 +1769,8 @@ xferOptimization(Parse * pParse,/* Parser context */
>> int regData, regTupleid;/* Registers holding data and tupleid */
>> struct session *user_session = current_session();
>> -if (pSelect == 0) {
>> +if (pSelect == 0)
> 2. == NULL.

Typo. Fixed on branch:

-       if (pSelect == 0)
+       if (pSelect == NULL)





More information about the Tarantool-patches mailing list